Adding gr_xmlrunner.py to Makefile.
[debian/gnuradio] / gnuradio-core / src / python / gnuradio / Makefile.am
index 0d53a11cc60bbf185881bdbfec02890e73bd8741..a3f3518dee8d2a3d9593648f027de58cc821c439 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004 Free Software Foundation, Inc.
+# Copyright 2004,2007,2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -21,7 +21,8 @@
 
 include $(top_srcdir)/Makefile.common
 
-SUBDIRS = gr gru gruimpl blks blksimpl blks2 blksimpl2
+if PYTHON
+SUBDIRS = gr gru gruimpl blks2 blks2impl vocoder
 
 grpython_PYTHON =                      \
        __init__.py                     \
@@ -29,9 +30,12 @@ grpython_PYTHON =                    \
        eng_notation.py                 \
        eng_option.py                   \
        modulation_utils.py             \
+       modulation_utils2.py            \
+       ofdm_packet_utils.py            \
        packet_utils.py                 \
        gr_unittest.py                  \
+       gr_xmlrunner.py                 \
        optfir.py                       \
+       usrp_options.py         \
        window.py
-
-CLEANFILES = *.pyc
+endif