rearrange includes to always be: internal GR, external, with GR.
[debian/gnuradio] / gnuradio-core / src / lib / swig / Makefile.am
index 75b152dc0b52109cf0be208eb161fc749282f880..1a50b8c8e90cde7fbf8ade5d4581c28fcf575de2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2001,2003,2004,2005,2006,2007,2008,2009 Free Software Foundation, Inc.
+# Copyright 2001,2003,2004,2005,2006,2007,2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -21,7 +21,8 @@
 
 include $(top_srcdir)/Makefile.common
 
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) -I$(srcdir) \
+if PYTHON
+AM_CPPFLAGS = -I$(srcdir) $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) \
         $(WITH_INCLUDES)
 
 EXTRA_DIST = gen-swig-bug-fix
@@ -99,3 +100,4 @@ BUILT_SOURCES =                              \
 
 # Do not distribute the output of SWIG
 no_dist_files = $(swig_built_sources)
+endif