Moving XML output files from cppunit tests to $HOME/.gnuradio/unittests.
[debian/gnuradio] / gnuradio-core / src / lib / runtime / Makefile.am
index 4b51f7f4de4db8bbd0ae8c3d90b6a42fcf8cce8e..abd789a1d07a2d4d1d42b457a3267fe227358bc4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2003,2004,2007 Free Software Foundation, Inc.
+# Copyright 2003,2004,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -21,7 +21,7 @@
 
 include $(top_srcdir)/Makefile.common
 
-INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES)
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES) $(GRUEL_INCLUDES) $(WITH_INCLUDES)
 
 noinst_LTLIBRARIES = libruntime.la libruntime-qa.la
 
@@ -35,6 +35,7 @@ libruntime_la_SOURCES =                       \
        gr_flat_flowgraph.cc                    \
        gr_block.cc                             \
        gr_block_detail.cc                      \
+       gr_block_executor.cc                    \
        gr_hier_block2.cc                       \
        gr_hier_block2_detail.cc                \
        gr_buffer.cc                            \
@@ -43,19 +44,25 @@ libruntime_la_SOURCES =                     \
        gr_io_signature.cc                      \
        gr_local_sighandler.cc                  \
        gr_message.cc                           \
+       gr_msg_accepter.cc                      \
        gr_msg_handler.cc                       \
        gr_msg_queue.cc                         \
        gr_pagesize.cc                          \
        gr_preferences.cc                       \
        gr_realtime.cc                          \
-       gr_scheduler_thread.cc                  \
+       gr_scheduler.cc                         \
+       gr_scheduler_sts.cc                     \
+       gr_scheduler_tpb.cc                     \
        gr_single_threaded_scheduler.cc         \
+       gr_sptr_magic.cc                        \
        gr_sync_block.cc                        \
        gr_sync_decimator.cc                    \
        gr_sync_interpolator.cc                 \
+       gr_tmp_path.cc                          \
        gr_top_block.cc                         \
        gr_top_block_impl.cc                    \
-       gr_tmp_path.cc                          \
+       gr_tpb_detail.cc                        \
+       gr_tpb_thread_body.cc                   \
        gr_vmcircbuf.cc                         \
        gr_vmcircbuf_mmap_shm_open.cc           \
        gr_vmcircbuf_mmap_tmpfile.cc            \
@@ -66,6 +73,7 @@ libruntime_la_SOURCES =                       \
 libruntime_qa_la_SOURCES =                     \
        qa_gr_block.cc                          \
        qa_gr_hier_block2.cc                    \
+       qa_gr_hier_block2_derived.cc            \
        qa_gr_buffer.cc                         \
        qa_gr_flowgraph.cc                      \
        qa_gr_top_block.cc                      \
@@ -79,6 +87,7 @@ grinclude_HEADERS =                           \
        gr_flat_flowgraph.h                     \
        gr_block.h                              \
        gr_block_detail.h                       \
+       gr_block_executor.h                     \
        gr_hier_block2.h                        \
        gr_hier_block2_detail.h                 \
        gr_buffer.h                             \
@@ -88,23 +97,30 @@ grinclude_HEADERS =                                 \
        gr_io_signature.h                       \
        gr_local_sighandler.h                   \
        gr_message.h                            \
+       gr_msg_accepter.h                       \
        gr_msg_handler.h                        \
        gr_msg_queue.h                          \
        gr_pagesize.h                           \
        gr_preferences.h                        \
        gr_realtime.h                           \
        gr_runtime_types.h                      \
-       gr_scheduler_thread.h                   \
+       gr_scheduler.h                          \
+       gr_scheduler_sts.h                      \
+       gr_scheduler_tpb.h                      \
        gr_select_handler.h                     \
        gr_single_threaded_scheduler.h          \
+       gr_sptr_magic.h                         \
        gr_sync_block.h                         \
        gr_sync_decimator.h                     \
        gr_sync_interpolator.h                  \
        gr_top_block.h                          \
        gr_top_block_impl.h                     \
+       gr_tpb_detail.h                         \
+       gr_tpb_thread_body.h                    \
        gr_timer.h                              \
        gr_tmp_path.h                           \
        gr_types.h                              \
+       gr_unittests.h                          \
        gr_vmcircbuf.h                          
 
 noinst_HEADERS =                               \
@@ -115,12 +131,14 @@ noinst_HEADERS =                          \
        qa_gr_block.h                           \
        qa_gr_flowgraph.h                       \
        qa_gr_hier_block2.h                     \
+       qa_gr_hier_block2_derived.h             \
        qa_gr_buffer.h                          \
        qa_gr_io_signature.h                    \
        qa_gr_top_block.h                       \
        qa_gr_vmcircbuf.h                       \
        qa_runtime.h                            
 
+if PYTHON
 swiginclude_HEADERS =                  \
        gr_basic_block.i                \
        gr_block.i                      \
@@ -138,8 +156,6 @@ swiginclude_HEADERS =                       \
        gr_sync_block.i                 \
        gr_sync_decimator.i             \
        gr_sync_interpolator.i          \
-       gr_swig_block_magic.i           \
        gr_top_block.i                  \
        runtime.i
-
-MOSTLYCLEANFILES = *~ *.loT
+endif