Adding a band-edge based frequency lock loop.
[debian/gnuradio] / gnuradio-core / src / lib / general / Makefile.am
index 3856a319af0115edcc735df0243272b28270c647..ecef7d6e3a910489e304477ba921a998e61f6f4e 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2001,2002,2004,2006,2007 Free Software Foundation, Inc.
+# Copyright 2001,2002,2004,2006,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -21,7 +21,7 @@
 
 include $(top_srcdir)/Makefile.common
 
-INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES)
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES)
 
 noinst_LTLIBRARIES = libgeneral.la libgeneral-qa.la
 
@@ -31,7 +31,7 @@ BUILT_SOURCES =
 
 EXTRA_DIST =                           \
        gen_sine_table.py               \
-       gr_prefix.cc.in                 
+       gr_constants.cc.in                      
 
 libgeneral_la_SOURCES =                \
        gr_agc_cc.cc                    \
@@ -51,35 +51,46 @@ libgeneral_la_SOURCES =             \
        gr_complex_to_interleaved_short.cc \
        gr_complex_to_xxx.cc            \
        gr_conjugate_cc.cc              \
+       gr_copy.cc                      \
        gr_constellation_decoder_cb.cc  \
        gr_correlate_access_code_bb.cc  \
        gr_costas_loop_cc.cc            \
        gr_count_bits.cc                \
+       gr_cpfsk_bc.cc                  \
        gr_crc32.cc                     \
        gr_ctcss_squelch_ff.cc          \
        gr_dd_mpsk_sync_cc.cc           \
+       gr_decode_ccsds_27_fb.cc        \
        gr_deinterleave.cc              \
+       gr_delay.cc                     \
        gr_diff_decoder_bb.cc           \
        gr_diff_encoder_bb.cc           \
        gr_diff_phasor_cc.cc            \
+       gr_dpll_bb.cc                   \
+       gr_encode_ccsds_27_bb.cc        \
        gr_fake_channel_coder_pp.cc     \
        gr_fast_atan2f.cc               \
        gr_feedforward_agc_cc.cc        \
        gr_feval.cc                     \
        gr_fft_vcc.cc                   \
+       gr_fft_vcc_fftw.cc              \
        gr_fft_vfc.cc                   \
        gr_firdes.cc                    \
+       gr_fll_band_edge_cc.cc          \
        gr_float_to_char.cc             \
        gr_float_to_complex.cc          \
        gr_float_to_short.cc            \
        gr_float_to_uchar.cc            \
+       gr_fmdet_cf.cc                  \
        gr_frequency_modulator_fc.cc    \
        gr_fxpt.cc                      \
        gr_framer_sink_1.cc             \
        gr_glfsr_source_b.cc            \
+       gr_glfsr_source_f.cc            \
        gr_head.cc                      \
        gr_interleave.cc                \
        gr_interleaved_short_to_complex.cc \
+       gr_iqcomp_cc.cc                 \
        gr_keep_one_in_n.cc             \
        gr_kludge_copy.cc               \
        gr_lfsr_32k_source_s.cc         \
@@ -93,22 +104,35 @@ libgeneral_la_SOURCES =            \
        gr_nop.cc                       \
        gr_null_sink.cc                 \
        gr_null_source.cc               \
+       gr_ofdm_frame_acquisition.cc    \
+        gr_ofdm_cyclic_prefixer.cc      \
+        gr_ofdm_demapper_vcb.cc         \
+        gr_ofdm_mapper_bcv.cc           \
+       gr_ofdm_frame_sink.cc           \
+       gr_ofdm_insert_preamble.cc      \
+        gr_ofdm_sampler.cc              \
        gr_pa_2x2_phase_combiner.cc     \
        gr_packet_sink.cc               \
+       gr_peak_detector2_fb.cc         \
        gr_phase_modulator_fc.cc        \
        gr_pll_carriertracking_cc.cc    \
        gr_pll_freqdet_cf.cc            \
        gr_pll_refout_cc.cc             \
-       gr_prefix.cc                    \
+       gr_pn_correlator_cc.cc          \
+       gr_constants.cc                 \
        gr_prefs.cc                     \
        gr_probe_avg_mag_sqrd_c.cc      \
+       gr_probe_avg_mag_sqrd_cf.cc     \
        gr_probe_avg_mag_sqrd_f.cc      \
        gr_probe_signal_f.cc            \
        gr_pwr_squelch_cc.cc            \
        gr_pwr_squelch_ff.cc            \
        gr_quadrature_demod_cf.cc       \
+       gr_rail_ff.cc                   \
        gr_random.cc                    \
+       gr_regenerate_bb.cc             \
        gr_remez.cc                     \
+       gr_repeat.cc                    \
        gr_reverse.cc                   \
        gr_rms_cf.cc                    \
        gr_rms_ff.cc                    \
@@ -117,12 +141,15 @@ libgeneral_la_SOURCES =           \
        gr_simple_framer.cc             \
        gr_simple_squelch_cc.cc         \
        gr_skiphead.cc                  \
+       gr_squash_ff.cc                 \
        gr_squelch_base_cc.cc           \
        gr_squelch_base_ff.cc           \
+       gr_stream_mux.cc                \
        gr_stream_to_streams.cc         \
        gr_stream_to_vector.cc          \
        gr_streams_to_stream.cc         \
        gr_streams_to_vector.cc         \
+       gr_stretch_ff.cc                \
         gr_test.cc                      \
        gr_threshold_ff.cc              \
        gr_throttle.cc                  \
@@ -130,6 +157,8 @@ libgeneral_la_SOURCES =             \
        gr_vco_f.cc                     \
        gr_vector_to_stream.cc          \
        gr_vector_to_streams.cc         \
+       gr_wavelet_ff.cc                \
+       gr_wvps_ff.cc                   \
        gri_add_const_ss_generic.cc     \
        gri_char_to_float.cc            \
        gri_debugger_hook.cc            \
@@ -142,7 +171,11 @@ libgeneral_la_SOURCES =            \
        gri_short_to_float.cc           \
        gri_uchar_to_float.cc           \
        malloc16.c                      \
-       gr_unpack_k_bits_bb.cc
+       gr_unpack_k_bits_bb.cc          \
+       gr_descrambler_bb.cc            \
+       gr_scrambler_bb.cc              \
+       gr_probe_mpsk_snr_c.cc          \
+       gr_probe_density_b.cc
 
 libgeneral_qa_la_SOURCES =             \
        qa_general.cc                   \
@@ -150,9 +183,9 @@ libgeneral_qa_la_SOURCES =          \
        qa_gr_firdes.cc                 \
        qa_gr_fxpt.cc                   \
        qa_gr_fxpt_nco.cc               \
-       qa_gr_fxpt_vco.cc               
-
-
+       qa_gr_fxpt_vco.cc               \
+       qa_gr_math.cc                   \
+       qa_gri_lfsr.cc
 
 grinclude_HEADERS =                    \
        gr_agc_cc.h                     \
@@ -173,36 +206,47 @@ grinclude_HEADERS =                       \
        gr_complex_to_xxx.h             \
        gr_conjugate_cc.h               \
        gr_constellation_decoder_cb.h   \
+       gr_copy.h                       \
        gr_correlate_access_code_bb.h   \
        gr_costas_loop_cc.h             \
        gr_count_bits.h                 \
+       gr_cpfsk_bc.h                   \
        gr_crc32.h                      \
        gr_ctcss_squelch_ff.h           \
        gr_dd_mpsk_sync_cc.h            \
+       gr_decode_ccsds_27_fb.h         \
        gr_diff_decoder_bb.h            \
        gr_diff_encoder_bb.h            \
        gr_deinterleave.h               \
+       gr_delay.h                      \
        gr_diff_phasor_cc.h             \
+       gr_dpll_bb.h                    \
+       gr_encode_ccsds_27_bb.h         \
        gr_expj.h                       \
        gr_fake_channel_coder_pp.h      \
        gr_feedforward_agc_cc.h         \
        gr_feval.h                      \
        gr_fft_vcc.h                    \
+       gr_fft_vcc_fftw.h               \
        gr_fft_vfc.h                    \
        gr_firdes.h                     \
+       gr_fll_band_edge_cc.h           \
        gr_float_to_char.h              \
        gr_float_to_complex.h           \
        gr_float_to_short.h             \
        gr_float_to_uchar.h             \
+       gr_fmdet_cf.h                   \
        gr_framer_sink_1.h              \
        gr_frequency_modulator_fc.h     \
        gr_fxpt.h                       \
        gr_fxpt_nco.h                   \
        gr_fxpt_vco.h                   \
        gr_glfsr_source_b.h             \
+       gr_glfsr_source_f.h             \
        gr_head.h                       \
        gr_interleave.h                 \
        gr_interleaved_short_to_complex.h \
+       gr_iqcomp_cc.h                  \
        gr_keep_one_in_n.h              \
        gr_kludge_copy.h                \
        gr_lfsr_32k_source_s.h          \
@@ -218,22 +262,35 @@ grinclude_HEADERS =                       \
        gr_nop.h                        \
        gr_null_sink.h                  \
        gr_null_source.h                \
+       gr_ofdm_frame_acquisition.h     \
+        gr_ofdm_cyclic_prefixer.h       \
+        gr_ofdm_demapper_vcb.h          \
+        gr_ofdm_mapper_bcv.h            \
+        gr_ofdm_frame_sink.h           \
+       gr_ofdm_insert_preamble.h       \
+       gr_ofdm_sampler.h               \
        gr_pa_2x2_phase_combiner.h      \
        gr_packet_sink.h                \
+       gr_peak_detector2_fb.h          \
        gr_phase_modulator_fc.h         \
        gr_pll_carriertracking_cc.h     \
        gr_pll_freqdet_cf.h             \
        gr_pll_refout_cc.h              \
-       gr_prefix.h                     \
+       gr_pn_correlator_cc.h           \
+       gr_constants.h                  \
        gr_prefs.h                      \
        gr_probe_avg_mag_sqrd_c.h       \
+       gr_probe_avg_mag_sqrd_cf.h      \
        gr_probe_avg_mag_sqrd_f.h       \
        gr_probe_signal_f.h             \
        gr_pwr_squelch_cc.h             \
        gr_pwr_squelch_ff.h             \
        gr_quadrature_demod_cf.h        \
+       gr_rail_ff.h                    \
        gr_random.h                     \
+       gr_regenerate_bb.h              \
        gr_remez.h                      \
+       gr_repeat.h                     \
        gr_reverse.h                    \
        gr_rms_cf.h                     \
        gr_rms_ff.h                     \
@@ -242,13 +299,16 @@ grinclude_HEADERS =                       \
        gr_simple_framer.h              \
        gr_simple_framer_sync.h         \
        gr_simple_squelch_cc.h          \
+       gr_squash_ff.h                  \
        gr_skiphead.h                   \
        gr_squelch_base_cc.h            \
        gr_squelch_base_ff.h            \
+       gr_stream_mux.h                 \
        gr_stream_to_streams.h          \
        gr_stream_to_vector.h           \
        gr_streams_to_stream.h          \
        gr_streams_to_vector.h          \
+       gr_stretch_ff.h                 \
         gr_test_types.h                        \
         gr_test.h                      \
        gr_threshold_ff.h               \
@@ -258,6 +318,8 @@ grinclude_HEADERS =                         \
        gr_vco_f.h                      \
        gr_vector_to_stream.h           \
        gr_vector_to_streams.h          \
+       gr_wavelet_ff.h                 \
+       gr_wvps_ff.h                    \
        gri_add_const_ss.h              \
        gri_agc_cc.h                    \
        gri_agc_ff.h                    \
@@ -269,6 +331,7 @@ grinclude_HEADERS =                         \
        gri_float_to_char.h             \
        gri_float_to_short.h            \
        gri_float_to_uchar.h            \
+       gri_lfsr.h                      \
        gri_glfsr.h                     \
        gri_interleaved_short_to_complex.h \
        gri_lfsr_15_1_0.h               \
@@ -277,8 +340,11 @@ grinclude_HEADERS =                        \
        gri_uchar_to_float.h            \
        malloc16.h                      \
        random.h                        \
-       gr_unpack_k_bits_bb.h
-
+       gr_unpack_k_bits_bb.h           \
+       gr_descrambler_bb.h             \
+       gr_scrambler_bb.h               \
+       gr_probe_mpsk_snr_c.h           \
+       gr_probe_density_b.h
 
 noinst_HEADERS =                       \
        qa_general.h                    \
@@ -287,8 +353,11 @@ noinst_HEADERS =                   \
        qa_gr_fxpt.h                    \
        qa_gr_fxpt_nco.h                \
        qa_gr_fxpt_vco.h                \
-       sine_table.h                    
+       qa_gri_lfsr.h                   \
+       sine_table.h                    \
+       qa_gr_math.h
 
+if PYTHON
 swiginclude_HEADERS =                  \
        general.i                       \
        gr_agc_cc.i                     \
@@ -308,31 +377,41 @@ swiginclude_HEADERS =                     \
        gr_complex_to_xxx.i             \
        gr_conjugate_cc.i               \
        gr_constellation_decoder_cb.i   \
+       gr_copy.i                       \
        gr_correlate_access_code_bb.i   \
        gr_costas_loop_cc.i             \
+       gr_cpfsk_bc.i                   \
        gr_crc32.i                      \
        gr_ctcss_squelch_ff.i           \
        gr_dd_mpsk_sync_cc.i            \
+       gr_decode_ccsds_27_fb.i         \
        gr_diff_decoder_bb.i            \
        gr_diff_encoder_bb.i            \
        gr_diff_phasor_cc.i             \
+       gr_dpll_bb.i                    \
        gr_deinterleave.i               \
+       gr_delay.i                      \
+       gr_encode_ccsds_27_bb.i         \
        gr_fake_channel_coder_pp.i      \
        gr_feedforward_agc_cc.i         \
        gr_feval.i                      \
        gr_fft_vcc.i                    \
        gr_fft_vfc.i                    \
        gr_firdes.i                     \
+       gr_fll_band_edge_cc.i           \
        gr_float_to_char.i              \
        gr_float_to_complex.i           \
        gr_float_to_short.i             \
        gr_float_to_uchar.i             \
+       gr_fmdet_cf.i                   \
        gr_frequency_modulator_fc.i     \
        gr_framer_sink_1.i              \
        gr_glfsr_source_b.i             \
+       gr_glfsr_source_f.i             \
        gr_head.i                       \
        gr_interleave.i                 \
        gr_interleaved_short_to_complex.i \
+       gr_iqcomp_cc.i                  \
        gr_keep_one_in_n.i              \
        gr_kludge_copy.i                \
        gr_lfsr_32k_source_s.i          \
@@ -344,34 +423,50 @@ swiginclude_HEADERS =                     \
        gr_nop.i                        \
        gr_null_sink.i                  \
        gr_null_source.i                \
+       gr_ofdm_frame_acquisition.i     \
+        gr_ofdm_cyclic_prefixer.i       \
+        gr_ofdm_demapper_vcb.i          \
+        gr_ofdm_mapper_bcv.i            \
+        gr_ofdm_frame_sink.i           \
+       gr_ofdm_insert_preamble.i       \
+       gr_ofdm_sampler.i               \
        gr_pa_2x2_phase_combiner.i      \
        gr_packet_sink.i                \
+       gr_peak_detector2_fb.i          \
        gr_phase_modulator_fc.i         \
        gr_pll_carriertracking_cc.i     \
        gr_pll_freqdet_cf.i             \
        gr_pll_refout_cc.i              \
-       gr_prefix.i                     \
+       gr_pn_correlator_cc.i           \
+       gr_constants.i                  \
        gr_prefs.i                      \
        gr_probe_avg_mag_sqrd_c.i       \
+       gr_probe_avg_mag_sqrd_cf.i      \
        gr_probe_avg_mag_sqrd_f.i       \
        gr_probe_signal_f.i             \
        gr_pwr_squelch_cc.i             \
        gr_pwr_squelch_ff.i             \
        gr_quadrature_demod_cf.i        \
+       gr_rail_ff.i                    \
+       gr_regenerate_bb.i              \
        gr_remez.i                      \
        gr_rms_cf.i                     \
        gr_rms_ff.i                     \
+       gr_repeat.i                     \
        gr_short_to_float.i             \
        gr_simple_correlator.i          \
        gr_simple_framer.i              \
        gr_simple_squelch_cc.i          \
        gr_skiphead.i                   \
+       gr_squash_ff.i                  \
        gr_squelch_base_cc.i            \
        gr_squelch_base_ff.i            \
+       gr_stream_mux.i                 \
        gr_stream_to_streams.i          \
        gr_stream_to_vector.i           \
        gr_streams_to_stream.i          \
        gr_streams_to_vector.i          \
+       gr_stretch_ff.i                 \
         gr_test.i                      \
        gr_threshold_ff.i               \
        gr_throttle.i                   \
@@ -380,10 +475,14 @@ swiginclude_HEADERS =                     \
        gr_vector_to_stream.i           \
        gr_vector_to_streams.i          \
        gr_unpack_k_bits_bb.i           \
+       gr_wavelet_ff.i                 \
+       gr_wvps_ff.i                    \
        gri_agc_cc.i                    \
        gri_agc_ff.i                    \
        gri_agc2_cc.i                   \
-       gri_agc2_ff.i                   
-
-
-CLEANFILES = $(BUILT_SOURCES) *.pyc
+       gri_agc2_ff.i                   \
+       gr_descrambler_bb.i             \
+       gr_scrambler_bb.i               \
+       gr_probe_mpsk_snr_c.i           \
+       gr_probe_density_b.i
+endif