Adding a band-edge based frequency lock loop.
[debian/gnuradio] / gnuradio-core / src / lib / general / Makefile.am
index 0243632532dbe53354488a7e433d70ad295d47d2..ecef7d6e3a910489e304477ba921a998e61f6f4e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2001,2002,2004,2006,2007,2008 Free Software Foundation, Inc.
+# Copyright 2001,2002,2004,2006,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -31,7 +31,7 @@ BUILT_SOURCES =
 
 EXTRA_DIST =                           \
        gen_sine_table.py               \
-       gr_prefix.cc.in                 
+       gr_constants.cc.in                      
 
 libgeneral_la_SOURCES =                \
        gr_agc_cc.cc                    \
@@ -51,6 +51,7 @@ libgeneral_la_SOURCES =               \
        gr_complex_to_interleaved_short.cc \
        gr_complex_to_xxx.cc            \
        gr_conjugate_cc.cc              \
+       gr_copy.cc                      \
        gr_constellation_decoder_cb.cc  \
        gr_correlate_access_code_bb.cc  \
        gr_costas_loop_cc.cc            \
@@ -75,10 +76,12 @@ libgeneral_la_SOURCES =             \
        gr_fft_vcc_fftw.cc              \
        gr_fft_vfc.cc                   \
        gr_firdes.cc                    \
+       gr_fll_band_edge_cc.cc          \
        gr_float_to_char.cc             \
        gr_float_to_complex.cc          \
        gr_float_to_short.cc            \
        gr_float_to_uchar.cc            \
+       gr_fmdet_cf.cc                  \
        gr_frequency_modulator_fc.cc    \
        gr_fxpt.cc                      \
        gr_framer_sink_1.cc             \
@@ -116,7 +119,7 @@ libgeneral_la_SOURCES =             \
        gr_pll_freqdet_cf.cc            \
        gr_pll_refout_cc.cc             \
        gr_pn_correlator_cc.cc          \
-       gr_prefix.cc                    \
+       gr_constants.cc                 \
        gr_prefs.cc                     \
        gr_probe_avg_mag_sqrd_c.cc      \
        gr_probe_avg_mag_sqrd_cf.cc     \
@@ -125,6 +128,7 @@ libgeneral_la_SOURCES =             \
        gr_pwr_squelch_cc.cc            \
        gr_pwr_squelch_ff.cc            \
        gr_quadrature_demod_cf.cc       \
+       gr_rail_ff.cc                   \
        gr_random.cc                    \
        gr_regenerate_bb.cc             \
        gr_remez.cc                     \
@@ -137,6 +141,7 @@ libgeneral_la_SOURCES =             \
        gr_simple_framer.cc             \
        gr_simple_squelch_cc.cc         \
        gr_skiphead.cc                  \
+       gr_squash_ff.cc                 \
        gr_squelch_base_cc.cc           \
        gr_squelch_base_ff.cc           \
        gr_stream_mux.cc                \
@@ -144,6 +149,7 @@ libgeneral_la_SOURCES =             \
        gr_stream_to_vector.cc          \
        gr_streams_to_stream.cc         \
        gr_streams_to_vector.cc         \
+       gr_stretch_ff.cc                \
         gr_test.cc                      \
        gr_threshold_ff.cc              \
        gr_throttle.cc                  \
@@ -151,6 +157,8 @@ libgeneral_la_SOURCES =             \
        gr_vco_f.cc                     \
        gr_vector_to_stream.cc          \
        gr_vector_to_streams.cc         \
+       gr_wavelet_ff.cc                \
+       gr_wvps_ff.cc                   \
        gri_add_const_ss_generic.cc     \
        gri_char_to_float.cc            \
        gri_debugger_hook.cc            \
@@ -165,7 +173,9 @@ libgeneral_la_SOURCES =             \
        malloc16.c                      \
        gr_unpack_k_bits_bb.cc          \
        gr_descrambler_bb.cc            \
-       gr_scrambler_bb.cc
+       gr_scrambler_bb.cc              \
+       gr_probe_mpsk_snr_c.cc          \
+       gr_probe_density_b.cc
 
 libgeneral_qa_la_SOURCES =             \
        qa_general.cc                   \
@@ -196,6 +206,7 @@ grinclude_HEADERS =                         \
        gr_complex_to_xxx.h             \
        gr_conjugate_cc.h               \
        gr_constellation_decoder_cb.h   \
+       gr_copy.h                       \
        gr_correlate_access_code_bb.h   \
        gr_costas_loop_cc.h             \
        gr_count_bits.h                 \
@@ -219,10 +230,12 @@ grinclude_HEADERS =                       \
        gr_fft_vcc_fftw.h               \
        gr_fft_vfc.h                    \
        gr_firdes.h                     \
+       gr_fll_band_edge_cc.h           \
        gr_float_to_char.h              \
        gr_float_to_complex.h           \
        gr_float_to_short.h             \
        gr_float_to_uchar.h             \
+       gr_fmdet_cf.h                   \
        gr_framer_sink_1.h              \
        gr_frequency_modulator_fc.h     \
        gr_fxpt.h                       \
@@ -264,7 +277,7 @@ grinclude_HEADERS =                         \
        gr_pll_freqdet_cf.h             \
        gr_pll_refout_cc.h              \
        gr_pn_correlator_cc.h           \
-       gr_prefix.h                     \
+       gr_constants.h                  \
        gr_prefs.h                      \
        gr_probe_avg_mag_sqrd_c.h       \
        gr_probe_avg_mag_sqrd_cf.h      \
@@ -273,6 +286,7 @@ grinclude_HEADERS =                         \
        gr_pwr_squelch_cc.h             \
        gr_pwr_squelch_ff.h             \
        gr_quadrature_demod_cf.h        \
+       gr_rail_ff.h                    \
        gr_random.h                     \
        gr_regenerate_bb.h              \
        gr_remez.h                      \
@@ -285,6 +299,7 @@ grinclude_HEADERS =                         \
        gr_simple_framer.h              \
        gr_simple_framer_sync.h         \
        gr_simple_squelch_cc.h          \
+       gr_squash_ff.h                  \
        gr_skiphead.h                   \
        gr_squelch_base_cc.h            \
        gr_squelch_base_ff.h            \
@@ -293,6 +308,7 @@ grinclude_HEADERS =                         \
        gr_stream_to_vector.h           \
        gr_streams_to_stream.h          \
        gr_streams_to_vector.h          \
+       gr_stretch_ff.h                 \
         gr_test_types.h                        \
         gr_test.h                      \
        gr_threshold_ff.h               \
@@ -302,6 +318,8 @@ grinclude_HEADERS =                         \
        gr_vco_f.h                      \
        gr_vector_to_stream.h           \
        gr_vector_to_streams.h          \
+       gr_wavelet_ff.h                 \
+       gr_wvps_ff.h                    \
        gri_add_const_ss.h              \
        gri_agc_cc.h                    \
        gri_agc_ff.h                    \
@@ -324,8 +342,9 @@ grinclude_HEADERS =                         \
        random.h                        \
        gr_unpack_k_bits_bb.h           \
        gr_descrambler_bb.h             \
-       gr_scrambler_bb.h
-
+       gr_scrambler_bb.h               \
+       gr_probe_mpsk_snr_c.h           \
+       gr_probe_density_b.h
 
 noinst_HEADERS =                       \
        qa_general.h                    \
@@ -338,6 +357,7 @@ noinst_HEADERS =                    \
        sine_table.h                    \
        qa_gr_math.h
 
+if PYTHON
 swiginclude_HEADERS =                  \
        general.i                       \
        gr_agc_cc.i                     \
@@ -357,6 +377,7 @@ swiginclude_HEADERS =                       \
        gr_complex_to_xxx.i             \
        gr_conjugate_cc.i               \
        gr_constellation_decoder_cb.i   \
+       gr_copy.i                       \
        gr_correlate_access_code_bb.i   \
        gr_costas_loop_cc.i             \
        gr_cpfsk_bc.i                   \
@@ -377,10 +398,12 @@ swiginclude_HEADERS =                     \
        gr_fft_vcc.i                    \
        gr_fft_vfc.i                    \
        gr_firdes.i                     \
+       gr_fll_band_edge_cc.i           \
        gr_float_to_char.i              \
        gr_float_to_complex.i           \
        gr_float_to_short.i             \
        gr_float_to_uchar.i             \
+       gr_fmdet_cf.i                   \
        gr_frequency_modulator_fc.i     \
        gr_framer_sink_1.i              \
        gr_glfsr_source_b.i             \
@@ -415,7 +438,7 @@ swiginclude_HEADERS =                       \
        gr_pll_freqdet_cf.i             \
        gr_pll_refout_cc.i              \
        gr_pn_correlator_cc.i           \
-       gr_prefix.i                     \
+       gr_constants.i                  \
        gr_prefs.i                      \
        gr_probe_avg_mag_sqrd_c.i       \
        gr_probe_avg_mag_sqrd_cf.i      \
@@ -424,6 +447,7 @@ swiginclude_HEADERS =                       \
        gr_pwr_squelch_cc.i             \
        gr_pwr_squelch_ff.i             \
        gr_quadrature_demod_cf.i        \
+       gr_rail_ff.i                    \
        gr_regenerate_bb.i              \
        gr_remez.i                      \
        gr_rms_cf.i                     \
@@ -434,6 +458,7 @@ swiginclude_HEADERS =                       \
        gr_simple_framer.i              \
        gr_simple_squelch_cc.i          \
        gr_skiphead.i                   \
+       gr_squash_ff.i                  \
        gr_squelch_base_cc.i            \
        gr_squelch_base_ff.i            \
        gr_stream_mux.i                 \
@@ -441,6 +466,7 @@ swiginclude_HEADERS =                       \
        gr_stream_to_vector.i           \
        gr_streams_to_stream.i          \
        gr_streams_to_vector.i          \
+       gr_stretch_ff.i                 \
         gr_test.i                      \
        gr_threshold_ff.i               \
        gr_throttle.i                   \
@@ -449,12 +475,14 @@ swiginclude_HEADERS =                     \
        gr_vector_to_stream.i           \
        gr_vector_to_streams.i          \
        gr_unpack_k_bits_bb.i           \
+       gr_wavelet_ff.i                 \
+       gr_wvps_ff.i                    \
        gri_agc_cc.i                    \
        gri_agc_ff.i                    \
        gri_agc2_cc.i                   \
        gri_agc2_ff.i                   \
        gr_descrambler_bb.i             \
-       gr_scrambler_bb.i
-
-
-CLEANFILES = $(BUILT_SOURCES) *.pyc
+       gr_scrambler_bb.i               \
+       gr_probe_mpsk_snr_c.i           \
+       gr_probe_density_b.i
+endif