Using generators to make gri_fir_filter_with_buffer_XXX into all possible in/out...
[debian/gnuradio] / gnuradio-core / src / lib / filter / Makefile.am
index d5afd571bac31bd10aba7d3f30858bae6a9b130f..31f919ba7745c1eb33f781208f2edee113198738 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2001,2002,2004,2005,2006,2007,2008,2009 Free Software Foundation, Inc.
+# Copyright 2001,2002,2004,2005,2006,2007,2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -44,6 +44,7 @@ code_generator =                                      \
        generate_gr_fir_sysconfig_generic.py            \
        generate_gr_fir_util.py                         \
        generate_gr_freq_xlating_fir_filter_XXX.py      \
+       generate_gri_fir_filter_with_buffer_XXX.py      \
        generate_utils.py                               \
        gr_fir_XXX.cc.t                                 \
        gr_fir_XXX.h.t                                  \
@@ -60,7 +61,11 @@ code_generator =                                     \
        gr_rational_resampler_base_XXX.i.t              \
        gr_freq_xlating_fir_filter_XXX.cc.t             \
        gr_freq_xlating_fir_filter_XXX.h.t              \
-       gr_freq_xlating_fir_filter_XXX.i.t
+       gr_freq_xlating_fir_filter_XXX.i.t              \
+       gri_fir_filter_with_buffer_XXX.cc.t             \
+       gri_fir_filter_with_buffer_XXX.h.t              \
+       gri_fir_filter_with_buffer_XXX.i.t
+
 
 # Source built by Python into $(builddir)
 BUILT_SOURCES =                        \
@@ -184,10 +189,13 @@ libfilter_la_common_SOURCES =             \
        $(GENERATED_CC)                 \
        gr_adaptive_fir_ccf.cc          \
        gr_cma_equalizer_cc.cc          \
+       gri_fft_filter_fff_generic.cc   \
+       gri_fft_filter_ccc_generic.cc   \
        gr_fft_filter_ccc.cc            \
        gr_fft_filter_fff.cc            \
        gr_goertzel_fc.cc               \
        gr_filter_delay_fc.cc           \
+       gri_fir_filter_with_buffer_ccf.cc \
        gr_fractional_interpolator_ff.cc \
        gr_fractional_interpolator_cc.cc \
        gr_hilbert_fc.cc                \
@@ -203,10 +211,12 @@ libfilter_la_common_SOURCES =             \
        float_dotprod_generic.c         \
        short_dotprod_generic.c         \
        gr_pfb_channelizer_ccf.cc       \
+       gr_pfb_synthesis_filterbank_ccf.cc\
        gr_pfb_decimator_ccf.cc         \
        gr_pfb_interpolator_ccf.cc      \
        gr_pfb_arb_resampler_ccf.cc     \
-       gr_pfb_clock_sync_ccf.cc
+       gr_pfb_clock_sync_ccf.cc        \
+       gr_pfb_clock_sync_fff.cc
 
 libfilter_qa_la_common_SOURCES =       \
        qa_filter.cc                    \
@@ -217,7 +227,8 @@ libfilter_qa_la_common_SOURCES =    \
        qa_gr_fir_scc.cc                \
        qa_gr_rotator.cc                \
        qa_gri_mmse_fir_interpolator.cc \
-       qa_gri_mmse_fir_interpolator_cc.cc      
+       qa_gri_mmse_fir_interpolator_cc.cc \
+       qa_gri_fir_filter_with_buffer_ccf.cc
 
 if MD_CPU_generic
 libfilter_la_SOURCES = $(libfilter_la_common_SOURCES) $(generic_CODE)
@@ -258,9 +269,12 @@ grinclude_HEADERS =                        \
        gr_altivec.h                    \
        gr_cma_equalizer_cc.h           \
        gr_cpu.h                        \
+       gri_fft_filter_fff_generic.h    \
+       gri_fft_filter_ccc_generic.h    \
        gr_fft_filter_ccc.h             \
        gr_fft_filter_fff.h             \
        gr_filter_delay_fc.h            \
+       gri_fir_filter_with_buffer_ccf.h \
        gr_fir_sysconfig_x86.h          \
        gr_fir_sysconfig_powerpc.h      \
        gr_fractional_interpolator_ff.h \
@@ -283,10 +297,12 @@ grinclude_HEADERS =                       \
        short_dotprod_x86.h             \
        sse_debug.h                     \
        gr_pfb_channelizer_ccf.h        \
+       gr_pfb_synthesis_filterbank_ccf.h\
        gr_pfb_decimator_ccf.h          \
        gr_pfb_interpolator_ccf.h       \
        gr_pfb_arb_resampler_ccf.h      \
-       gr_pfb_clock_sync_ccf.h
+       gr_pfb_clock_sync_ccf.h         \
+       gr_pfb_clock_sync_fff.h
 
 noinst_HEADERS =                       \
        assembly.h                      \
@@ -318,7 +334,8 @@ noinst_HEADERS =                    \
        qa_gr_fir_scc.h                 \
        qa_gr_rotator.h                 \
        qa_gri_mmse_fir_interpolator.h  \
-       qa_gri_mmse_fir_interpolator_cc.h       
+       qa_gri_mmse_fir_interpolator_cc.h \
+       qa_gri_fir_filter_with_buffer_ccf.h
 
 
 if PYTHON
@@ -338,10 +355,12 @@ swiginclude_HEADERS =                     \
        gr_single_pole_iir_filter_ff.i  \
        gr_single_pole_iir_filter_cc.i  \
        gr_pfb_channelizer_ccf.i        \
+       gr_pfb_synthesis_filterbank_ccf.i\
        gr_pfb_decimator_ccf.i          \
        gr_pfb_interpolator_ccf.i       \
        gr_pfb_arb_resampler_ccf.i      \
        gr_pfb_clock_sync_ccf.i         \
+       gr_pfb_clock_sync_fff.i         \
        $(GENERATED_I)
 endif