Adding clock sync algorithm using PFB. This works, but needs a bit more work.
[debian/gnuradio] / gnuradio-core / src / lib / filter / Makefile.am
index 838f69b92d39163d50c70719e664bef960121eb3..d5afd571bac31bd10aba7d3f30858bae6a9b130f 100644 (file)
@@ -205,7 +205,8 @@ libfilter_la_common_SOURCES =               \
        gr_pfb_channelizer_ccf.cc       \
        gr_pfb_decimator_ccf.cc         \
        gr_pfb_interpolator_ccf.cc      \
-       gr_pfb_arb_resampler_ccf.cc
+       gr_pfb_arb_resampler_ccf.cc     \
+       gr_pfb_clock_sync_ccf.cc
 
 libfilter_qa_la_common_SOURCES =       \
        qa_filter.cc                    \
@@ -284,7 +285,8 @@ grinclude_HEADERS =                         \
        gr_pfb_channelizer_ccf.h        \
        gr_pfb_decimator_ccf.h          \
        gr_pfb_interpolator_ccf.h       \
-       gr_pfb_arb_resampler_ccf.h
+       gr_pfb_arb_resampler_ccf.h      \
+       gr_pfb_clock_sync_ccf.h
 
 noinst_HEADERS =                       \
        assembly.h                      \
@@ -339,6 +341,7 @@ swiginclude_HEADERS =                       \
        gr_pfb_decimator_ccf.i          \
        gr_pfb_interpolator_ccf.i       \
        gr_pfb_arb_resampler_ccf.i      \
+       gr_pfb_clock_sync_ccf.i         \
        $(GENERATED_I)
 endif