Implements ticket:401 and ticket:402.
[debian/gnuradio] / gnuradio-core / src / lib / Makefile.am
index 171c85edda8b3b104987f18c86e81442b30ba403..8b2dc82ccc35dc8e1ab907147d81796c01b4394a 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2001,2004 Free Software Foundation, Inc.
+# Copyright 2001,2004,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -24,7 +24,12 @@ include $(top_srcdir)/Makefile.common
 ## Process this file with automake to produce Makefile.in
 
 # We've got to build . before swig
-SUBDIRS = missing runtime filter general gengen g72x reed-solomon io . swig
+SUBDIRS = missing runtime filter viterbi general gengen g72x reed-solomon io hier .
+if PYTHON
+SUBDIRS += swig
+endif
+
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES)
 
 # generate libgnuradio-core.la from the convenience libraries in subdirs
 
@@ -36,22 +41,32 @@ libgnuradio_core_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0
 libgnuradio_core_qa_la_SOURCES = bug_work_around_6.cc
 libgnuradio_core_qa_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0 \
                                 $(LIBGNURADIO_CORE_EXTRA_LDFLAGS)
+
+
 libgnuradio_core_la_LIBADD  =          \
        filter/libfilter.la             \
        g72x/libccitt.la                \
+       viterbi/libviterbi.la           \
        general/libgeneral.la           \
        gengen/libgengen.la             \
        io/libio.la                     \
        missing/libmissing.la           \
        reed-solomon/librs.la           \
        runtime/libruntime.la           \
+       hier/libhier.la                 \
        $(OMNITHREAD_LA)                \
-       $(FFTW3F_LIBS)
+       $(GRUEL_LA)                     \
+       $(FFTW3F_LIBS)                  \
+       $(GSL_LIBS)                     \
+       $(CBLAS_LIBS)                   
 
 libgnuradio_core_qa_la_LIBADD  =       \
        filter/libfilter-qa.la          \
        general/libgeneral-qa.la        \
        runtime/libruntime-qa.la        \
-       missing/libmissing.la           \
        libgnuradio-core.la             \
        $(CPPUNIT_LIBS)                 
+
+bin_PROGRAMS = gnuradio
+gnuradio_SOURCES = gnuradio.cc
+gnuradio_LDADD = libgnuradio-core.la $(BOOST_PROGRAM_OPTIONS_LIB)