Merge commit 'upstream/3.3.0'
[debian/amanda] / gnulib / regenerate / regenerate
old mode 100755 (executable)
new mode 100644 (file)
index 6f42fa0..d7f3a97
@@ -4,7 +4,7 @@
 # same version as was used to generate the source in the repository,
 # run the following in your git repository:
 #
-#   git checkout 8d2524ce78ca107074727cbd8780c26a203a107c
+#   git checkout 09b8fa6cb737f6e091931c494cbd56d12b3ad08d
 
 # get to the project root
 cd `dirname $0`/../..
@@ -39,9 +39,10 @@ shopt -u nullglob
 ## Add your modules here, then see below if you need to patch them. ##
 ######################################################################
 
-GNULIB_MODULES="getaddrinfo lock visibility base64 physmem fsusage"
-GNULIB_MODULES="$GNULIB_MODULES mkdtemp getopt full-read full-write"
-GNULIB_MODULES="$GNULIB_MODULES lseek ftruncate fseeko ftello regex"
+GNULIB_MODULES="getaddrinfo lock base64 physmem fsusage"
+GNULIB_MODULES="$GNULIB_MODULES mkdtemp getopt-gnu full-read full-write"
+GNULIB_MODULES="$GNULIB_MODULES lseek ftruncate fseeko ftello regex environ"
+GNULIB_MODULES="$GNULIB_MODULES inet_pton"
 
 ######################################################################
 ## End modules                                                      ##
@@ -65,6 +66,10 @@ PATCH_DIR="`pwd`/gnulib/regenerate"
 patch -p0 < "${PATCH_DIR}/no-error.patch" || exit 1
 rm -f gnulib/Makefile.am.orig
 
+# Patch fsusage.h to not use 'bool', as it doesn't play nicely with
+# Perl on Mac OS X
+patch -p1 < "${PATCH_DIR}/fsusage-no-bool.patch" || exit 1
+
 # Add info to the makefile to ensure all this stuff gets put in
 # the distribution tarball
 (   echo ""