Merge commit 'upstream/3.2.0'
[debian/amanda] / gnulib / regenerate / regenerate
index 0265ca26558293c74e67baa017ecf2e3e7da37e2..57565d78ef319fba1b4e6e6531188524d94c25cd 100644 (file)
@@ -1,7 +1,10 @@
 #! /bin/bash
 
-# Gnulib files in zmanda repo are from gnulib CVS updated with:
-#   cvs update -D '2007-01-31 13:12:51 -0600'
+# Gnulib files in zmanda repo are from gnulib GIT.  To check out the
+# same version as was used to generate the source in the repository,
+# run the following in your git repository:
+#
+#   git checkout 09b8fa6cb737f6e091931c494cbd56d12b3ad08d
 
 # get to the project root
 cd `dirname $0`/../..
@@ -36,24 +39,22 @@ shopt -u nullglob
 ## Add your modules here, then see below if you need to patch them. ##
 ######################################################################
 
-GNULIB_MODULES="getaddrinfo lock visibility"
+GNULIB_MODULES="getaddrinfo lock base64 physmem fsusage"
+GNULIB_MODULES="$GNULIB_MODULES mkdtemp getopt-gnu full-read full-write"
+GNULIB_MODULES="$GNULIB_MODULES lseek ftruncate fseeko ftello regex environ"
+GNULIB_MODULES="$GNULIB_MODULES inet_pton"
 
 ######################################################################
 ## End modules                                                      ##
 ######################################################################
 
-# check out a brand new gnulib directory and gnulib.m4i
+# create a brand new gnulib directory
 
 "${GNULIB_TOOL}" --import \
         --dir=. --lib=libgnu --source-base=gnulib --m4-base=config/gnulib \
         --doc-base=doc --aux-dir=config --libtool --macro-prefix=gl \
         ${GNULIB_MODULES} || exit 1
 
-for filename in config/gnulib/*.m4
- do
-    echo "m4_include([$filename])"
-done > config/gnulib.m4i || exit 1
-
 ########################## DEVELOPERS! ###############################
 ## Add your patch commands here, or use sed invoacations, etc.      ##
 ## Please comment heavily!                                          ##
@@ -63,19 +64,19 @@ PATCH_DIR="`pwd`/gnulib/regenerate"
 
 # Patch Makefile.am to not error out on warnings
 patch -p0 < "${PATCH_DIR}/no-error.patch" || exit 1
-
-
-# Add John's patches to getaddrinfo.c for use in cygwin
-patch -p0 < "${PATCH_DIR}/getaddrinfo-cygwin.patch" || exit 1
-
+rm -f gnulib/Makefile.am.orig
 
 # Add info to the makefile to ensure all this stuff gets put in
 # the distribution tarball
 (   echo ""
     echo "# Make sure regenerate/* are in the distribution tarball"
-    echo "EXTRA_DIST += "`cd gnulib; find regenerate -name .svn -prune -o -type f -print `
+    echo "EXTRA_DIST += "`cd gnulib; find regenerate -name .svn -prune -o -type f -print | sort`
 ) >> gnulib/Makefile.am
 
+# remove .gitignore files, which ignore things we would like to see
+rm -f config/gnulib/.gitignore
+rm -f gnulib/.gitignore
+
 ######################################################################
 ## End patches                                                      ##
 ######################################################################