Imported Upstream version 2.6.1
[debian/amanda] / gnulib / regenerate / regenerate
old mode 100644 (file)
new mode 100755 (executable)
index 0265ca2..5669916
@@ -1,7 +1,10 @@
 #! /bin/bash
 
-# Gnulib files in zmanda repo are from gnulib CVS updated with:
-#   cvs update -D '2007-01-31 13:12:51 -0600'
+# Gnulib files in zmanda repo are from gnulib GIT.  To check out the
+# same version as was used to generate the source in the repository,
+# run the following in your git repository:
+#
+#   git checkout 03400ebfaa064922caf3767d6641d7e1cdc8cd1b
 
 # get to the project root
 cd `dirname $0`/../..
@@ -36,24 +39,20 @@ shopt -u nullglob
 ## Add your modules here, then see below if you need to patch them. ##
 ######################################################################
 
-GNULIB_MODULES="getaddrinfo lock visibility"
+GNULIB_MODULES="getaddrinfo lock visibility base64 physmem fsusage"
+GNULIB_MODULES="$GNULIB_MODULES mkdtemp getopt full-read full-write"
 
 ######################################################################
 ## End modules                                                      ##
 ######################################################################
 
-# check out a brand new gnulib directory and gnulib.m4i
+# create a brand new gnulib directory
 
 "${GNULIB_TOOL}" --import \
         --dir=. --lib=libgnu --source-base=gnulib --m4-base=config/gnulib \
         --doc-base=doc --aux-dir=config --libtool --macro-prefix=gl \
         ${GNULIB_MODULES} || exit 1
 
-for filename in config/gnulib/*.m4
- do
-    echo "m4_include([$filename])"
-done > config/gnulib.m4i || exit 1
-
 ########################## DEVELOPERS! ###############################
 ## Add your patch commands here, or use sed invoacations, etc.      ##
 ## Please comment heavily!                                          ##
@@ -64,16 +63,17 @@ PATCH_DIR="`pwd`/gnulib/regenerate"
 # Patch Makefile.am to not error out on warnings
 patch -p0 < "${PATCH_DIR}/no-error.patch" || exit 1
 
-
 # Add John's patches to getaddrinfo.c for use in cygwin
 patch -p0 < "${PATCH_DIR}/getaddrinfo-cygwin.patch" || exit 1
 
+# Add John's patches to eliminate restrict attributes.
+patch -p0 < "${PATCH_DIR}/no-restrict.patch" || exit 1
 
 # Add info to the makefile to ensure all this stuff gets put in
 # the distribution tarball
 (   echo ""
     echo "# Make sure regenerate/* are in the distribution tarball"
-    echo "EXTRA_DIST += "`cd gnulib; find regenerate -name .svn -prune -o -type f -print `
+    echo "EXTRA_DIST += "`cd gnulib; find regenerate -name .svn -prune -o -type f -print | sort`
 ) >> gnulib/Makefile.am
 
 ######################################################################