]> git.gag.com Git - debian/elilo/blobdiff - devschemes/Makefile
add support for building 32 and 64 bit targets
[debian/elilo] / devschemes / Makefile
index 6ac05af77a83f29ab2a138528cb1144c68d07ff5..5328cb1a46cf0c6ab9573817a1cc093366bbb0ad 100644 (file)
 # to use this program.
 #
 
-include ../Make.defaults
-include ../Make.rules
+SRCDIR = .
+
+VPATH = $(SRCDIR)
+
+include $(SRCDIR)/../Make.defaults
+include $(SRCDIR)/../Make.rules
+
+TOPDIR=$(SRCDIR)/..
 
-TOPDIR=$(CDIR)/..
 
 FILES=simple.o
 
@@ -40,7 +45,7 @@ all: $(TARGET)
 #      without doing make clean.
 #
 $(TARGET): $(FILES)
-       $(LD) -r -o $@ $(FILES)
+       $(LD) $(LD3264) -r -o $@ $(FILES)
 
 clean:
        $(RM) -f $(TARGET) $(FILES)