more post-quilt-era cleanup
[debian/cc1111] / debian / rules
index 34ba6db1862a089a73366f6f018ee3ea5e08a21a..fc2244c18c0be668548731bf4782c2ebbd5fe395 100755 (executable)
@@ -1,6 +1,5 @@
 #!/usr/bin/make -f
 
-include /usr/share/quilt/quilt.make
 export DH_VERBOSE=1
 
 # These are used for cross-compiling and for saving the configure script
@@ -10,6 +9,11 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 export HOME=$(CURDIR)/build
 
+CFLAGS = `dpkg-buildflags --get CFLAGS`
+CFLAGS += -Wall -Wno-comment
+LDFLAGS = `dpkg-buildflags --get LDFLAGS`
+CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
+
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -g -O0
        export STRIP=true
@@ -18,8 +22,7 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
 
-clean: clean-patched unpatch
-clean-patched:
+clean:
        dh_testdir
        dh_testroot
        # Clean up files that Makefile should have cleaned
@@ -54,7 +57,7 @@ clean-patched:
        dh_clean
 
 configure: configure-stamp
-configure-stamp: $(QUILT_STAMPFN)
+configure-stamp: 
        dh_testdir
        mkdir -p $(CURDIR)/build
        cp /usr/share/misc/config.sub sim/ucsim/config.sub
@@ -78,11 +81,13 @@ configure-stamp: $(QUILT_STAMPFN)
                --disable-z80-port 
        touch $@
 
-build: build-stamp
-build-stamp:  configure-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+build-stamp: configure-stamp
        dh_testdir
        $(MAKE)
-       cd doc && lyx -e ps sdccman.lyx
+#      cd doc && lyx -e ps sdccman.lyx
        touch $@
 
 install: install-stamp
@@ -93,7 +98,7 @@ install-stamp: build
        dh_prep
        $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr
        mkdir -p debian/tmp/usr/share/doc/cc1111
-       install -o root -g root -m 644 doc/sdccman.ps debian/tmp/usr/share/doc/cc1111
+#      install -o root -g root -m 644 doc/sdccman.ps debian/tmp/usr/share/doc/cc1111
        mv debian/tmp/usr/share/doc/sdcc/* debian/tmp/usr/share/doc/cc1111/
        # Add some scripts
        mkdir -p debian/tmp/usr/share/sdcc/scripts
@@ -157,4 +162,4 @@ binary-arch: install
        $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
 
 binary: binary-arch binary-indep
-.PHONY: build clean binary-indep binary-arch binary install install-arch install-indep
+.PHONY: build-indep build-arch build clean binary-indep binary-arch binary install install-arch install-indep