]> git.gag.com Git - debian/amanda/blobdiff - debian/rules
fix for dh_perl usage in face of private library
[debian/amanda] / debian / rules
index a26fcc19bcbfd7166ebe54e975130e5c9170e01a..f70023566feaf7cc41e29a06fbe78da6a34f4e88 100755 (executable)
@@ -42,7 +42,8 @@ configure-stamp:
                --with-ssh-security \
                --with-bsdtcp-security \
                --with-bsdudp-security \
-               --without-ipv6
+               --without-ipv6 \
+               --enable-s3-device
 
        touch missing
        touch configure-stamp
@@ -53,11 +54,6 @@ build-stamp: configure-stamp
        MAILER=/usr/bin/mail $(MAKE) CFLAGS="-O2 -g -Wall \
                -DAMANDATES_FILE='\"/var/lib/amanda/amandates\"' \
                -DIGNORE_TAR_ERRORS "
-ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
-ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
-       $(MAKE) check
-endif
-endif
        touch build-stamp
 
 clean:
@@ -97,7 +93,6 @@ binary-arch: build
        dh_compress -a
        dh_movefiles -a --sourcedir=debian/amanda-common
        rm -r $(r)/usr/share/amanda
-       rm $(s)/usr/lib/amanda/chg-mtx
        dh_fixperms -av
        # fix perms manually
        chown -R backup:backup debian/*/var/lib/*
@@ -137,7 +132,7 @@ binary-arch: build
                $(s)/usr/share/lintian/overrides/amanda-server
        dh_makeshlibs -pamanda-common --noscripts
        dh_installdeb -a
-       dh_perl -a
+       dh_perl -a usr/lib/amanda/perl
        dh_shlibdeps -a -l"debian/amanda-common/usr/lib:debian/amanda-client/usr/lib:debian/amanda-server/usr/lib"
        # strip out the non-versioned amanda-common references, we need
        # the versioned ones in the control file and dupes are ugly...