cobble a temporary changelog entry to keep this test build straight
[debian/gnuradio] / debian / rules
index d7d8a85bae15ef1fa4d0d6b3d6290633cfa52b0e..61b72878804c1c678541e56c67066cf83b05b6d7 100755 (executable)
@@ -15,14 +15,14 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp extract-stamp install-stamp
 
+       # Remove (possibly stale) pre-built Qt-generated moc files; they will
+       # be rebuilt using the current Qt moc.  Perhaps this should actually be
+       # part of 'make distclean' and these files not be distributed:
+       rm -f ./gr-qtgui/src/lib/*_moc.cc
+
        if [ -f Makefile ]; \
        then\
-               if [ -d .svn ]; \
-               then \
-                       $(MAKE) maintainer-clean; \
-               else \
-                       $(MAKE) distclean; \
-               fi; \
+               $(MAKE) maintainer-clean; \
        fi
 
        dh_clean
@@ -37,7 +37,7 @@ update:
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       [ -f ./configure ] || ./bootstrap
+       ./bootstrap
        ./configure \
                --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr \
@@ -62,7 +62,8 @@ build-stamp: configure-stamp
 extract: extract-stamp
 extract-stamp: build-stamp debian/gen-install-files.sh
        dh_testdir
-       sh debian/gen-install-files.sh
+       chmod +x debian/gen-install-files.sh dtools/bin/extract_install_filenames
+       debian/gen-install-files.sh
        touch $@
 
 install: install-stamp
@@ -82,21 +83,17 @@ install-stamp: extract-stamp debian/control
        done
 
        : # Deposit rule to allow group 'usrp' access to USRP hardware
-       install -m 0644 -D debian/libusrp.udev \
-               debian/tmp/etc/udev/rules.d/40-usrp.rules
+       install -m 0644 -D debian/libusrp0.udev \
+               debian/tmp/lib/udev/rules.d/40-usrp.rules
 
        : # Deposit rule to allow group 'usrp' access to USRP2 hardware
-       install -m 0644 -D debian/libusrp2.limits \
-               debian/tmp/etc/security/limits.d/libusrp2.limits
+       install -m 0644 -D debian/libusrp2-0.limits \
+               debian/tmp/etc/security/limits.d/libusrp2-0.limits
 
        : # Install custom grc.conf
        install -m 0644 -D debian/grc.conf \
                debian/tmp/etc/gnuradio/conf.d/grc.conf
 
-       : # Install custom prefs.py FIXME
-       install -m 0644 -D debian/prefs.py \
-               debian/tmp/usr/lib/python2.6/dist-packages/gnuradio/gr/prefs.py
-
        dh_install --sourcedir=debian/tmp
        touch $@
 
@@ -110,7 +107,7 @@ binary-common:
        dh_testroot
        dh_installchangelogs ChangeLog
        dh_installdocs
-       dh_pycentral
+       dh_python2
        dh_link
        dh_strip
        dh_compress