cobble a temporary changelog entry to keep this test build straight
[debian/gnuradio] / debian / rules
index 2bbec0fa4bc4e16b9c103673286e145b3670149e..61b72878804c1c678541e56c67066cf83b05b6d7 100755 (executable)
@@ -6,27 +6,23 @@ export DH_VERBOSE=1
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
 
-CFLAGS = -Wall -g
+export DH_PYCENTRAL=nomove
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
+DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp extract-stamp install-stamp
 
+       # Remove (possibly stale) pre-built Qt-generated moc files; they will
+       # be rebuilt using the current Qt moc.  Perhaps this should actually be
+       # part of 'make distclean' and these files not be distributed:
+       rm -f ./gr-qtgui/src/lib/*_moc.cc
+
        if [ -f Makefile ]; \
        then\
-               if [ -d .svn ]; \
-               then \
-                       $(MAKE) maintainer-clean; \
-               else \
-                       $(MAKE) distclean; \
-               fi; \
+               $(MAKE) maintainer-clean; \
        fi
 
        dh_clean
@@ -41,32 +37,37 @@ update:
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       [ -f ./configure ] || ./bootstrap
-       CFLAGS="$(CFLAGS)" ./configure \
-               --prefix=/usr --mandir=\$${prefix}/share/man \
-               --infodir=\$${prefix}/share/info --enable-shared \
-               --enable-doxygen --enable-html-docs \
-               --sysconfdir=/etc --enable-all-components \
-               --disable-gr-audio-osx --disable-gr-audio-windows \
-               --disable-gr-qtgui --disable-gcell --disable-gr-gcell \
-               --disable-gr-comedi --disable-usrp2-firmware
+       ./bootstrap
+       ./configure \
+               --build=$(DEB_BUILD_GNU_TYPE) \
+               --prefix=/usr \
+               --mandir=\$${prefix}/share/man \
+               --infodir=\$${prefix}/share/info \
+               --enable-shared \
+               --sysconfdir=/etc \
+               --enable-all-components \
+               --disable-gr-audio-osx \
+               --disable-gr-audio-windows \
+               --disable-gcell --disable-gr-gcell \
+               --disable-gr-comedi --disable-usrp2-firmware 
        touch configure-stamp
 
-extract: extract-stamp
-extract-stamp: configure-stamp debian/gen-install-files.sh
-       dh_testdir
-       debian/gen-install-files.sh 
-       touch $@
-
 build: build-stamp
-build-stamp: extract-stamp
+build-stamp: configure-stamp
 
-       $(MAKE) 
+       $(MAKE)
        $(MAKE) check
        touch $@
 
+extract: extract-stamp
+extract-stamp: build-stamp debian/gen-install-files.sh
+       dh_testdir
+       chmod +x debian/gen-install-files.sh dtools/bin/extract_install_filenames
+       debian/gen-install-files.sh
+       touch $@
+
 install: install-stamp
-install-stamp: build-stamp
+install-stamp: extract-stamp debian/control
        dh_testdir
        dh_testroot
        dh_clean -k
@@ -82,13 +83,22 @@ install-stamp: build-stamp
        done
 
        : # Deposit rule to allow group 'usrp' access to USRP hardware
-       install -m 0644 -D debian/libusrp.udev \
-               debian/tmp/etc/udev/rules.d/40-usrp.rules
+       install -m 0644 -D debian/libusrp0.udev \
+               debian/tmp/lib/udev/rules.d/40-usrp.rules
+
+       : # Deposit rule to allow group 'usrp' access to USRP2 hardware
+       install -m 0644 -D debian/libusrp2-0.limits \
+               debian/tmp/etc/security/limits.d/libusrp2-0.limits
+
+       : # Install custom grc.conf
+       install -m 0644 -D debian/grc.conf \
+               debian/tmp/etc/gnuradio/conf.d/grc.conf
 
        dh_install --sourcedir=debian/tmp
        touch $@
 
 
+
 # Must not depend on anything. This is to be called by
 # binary-arch/binary-indep
 # in another 'make' thread.
@@ -97,7 +107,7 @@ binary-common:
        dh_testroot
        dh_installchangelogs ChangeLog
        dh_installdocs
-       dh_pycentral
+       dh_python2
        dh_link
        dh_strip
        dh_compress