]> git.gag.com Git - debian/cpmtools/blobdiff - debian/rules
changelog for cleaned up clean target
[debian/cpmtools] / debian / rules
index 2d33f6ac8992b7da84b39a5bca0742c4962d3349..5e7e2bd5505c97923142677e6e6b7c952889a41c 100755 (executable)
@@ -1,4 +1,18 @@
 #!/usr/bin/make -f
 
 %:
-       dh $@
+       dh $@ --without autoreconf
+
+override_dh_auto_configure:
+       dh_auto_configure -- --datarootdir=/etc/cpmtools --with-libdsk=/usr
+
+override_dh_auto_clean:
+       rm -f *.1 *.5
+       dh_auto_clean
+
+override_dh_auto_install:
+       make install \
+               DESTDIR=$(CURDIR)/debian/cpmtools \
+               AM_UPDATE_INFO_DIR=no \
+               'INSTALL=install --strip-program=true'
+