update handling of inetd and xinetd config files to reflect change to use
[debian/amanda] / debian / rules
index c9c34fcda76bdbbe4ea00c30b2837b495cc2b4e9..3238716af248b9d9841328e8bed725d91fc37fbd 100755 (executable)
@@ -1,9 +1,7 @@
 #!/usr/bin/make -f
-# debian/rules for amanda using debhelper
-# Copyright 1998-2009 by Bdale Garbee.  License GPL v2
+# Copyright 1998-2011 by Bdale Garbee.  License GPL v2
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+export DH_VERBOSE=1
 
 r=$(shell pwd)/debian/amanda-common
 s=$(shell pwd)/debian/amanda-server
@@ -25,7 +23,7 @@ configure-stamp:
                --bindir=/usr/sbin \
                --libexecdir=/usr/lib/amanda \
                --without-amlibexecdir \
-               --with-amperldir=/usr/share/perl
+               --without-amperldir \
                --sysconfdir=/etc \
                --sharedstatedir=/var/lib \
                --localstatedir=/var/lib \
@@ -42,15 +40,18 @@ configure-stamp:
                --with-ssh-security \
                --with-bsdtcp-security \
                --with-bsdudp-security \
-               --without-ipv6
+               --without-ipv6 \
+               --enable-s3-device
 
        touch missing
        touch configure-stamp
 
-build: build-stamp 
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 build-stamp: configure-stamp
        dh_testdir
-       MAILER=/usr/bin/mail make CFLAGS="-O2 -g -Wall \
+       MAILER=/usr/bin/mail $(MAKE) CFLAGS="-O2 -g -Wall \
                -DAMANDATES_FILE='\"/var/lib/amanda/amandates\"' \
                -DIGNORE_TAR_ERRORS "
        touch build-stamp
@@ -77,13 +78,12 @@ binary-arch: build
        dh_clean -k
        dh_installdirs -a
        make install DESTDIR=$(r)
+       sed -i "/dependency_libs/ s/'.*'/''/" `find $(r)/usr/lib/amanda/ -name '*.la'`
        install -m 644 debian/amandahosts $(r)/etc/amandahosts
        dh_installdocs -a
        dh_installexamples -a
        cp ChangeLog $(r)/usr/share/doc/amanda-common/changelog
-       cp debian/xinetd.d/amandaidx $(s)/etc/xinetd.d
-       cp debian/xinetd.d/amidxtape $(s)/etc/xinetd.d
-       cp debian/xinetd.d/amanda $(r)/etc/xinetd.d                     
+       cp example/xinetd.amandaserver $(r)/etc/xinetd.d/amanda
        dh_installmenu -a
        dh_installcron -a
        dh_installchangelogs -a
@@ -91,7 +91,7 @@ binary-arch: build
        dh_strip -a
        dh_compress -a
        dh_movefiles -a --sourcedir=debian/amanda-common
-       rm $(s)/usr/lib/amanda/chg-mtx
+       rm -r $(r)/usr/share/amanda
        dh_fixperms -av
        # fix perms manually
        chown -R backup:backup debian/*/var/lib/*
@@ -104,6 +104,9 @@ binary-arch: build
        chmod -R u=rwX,g=rwX,o-rwx $(c)/var/lib/amanda/gnutar-lists
        # .. setuid
        chown root:backup \
+               $(c)/usr/lib/amanda/application/amgtar \
+               $(c)/usr/lib/amanda/application/amstar \
+               $(c)/usr/lib/amanda/calcsize \
                $(c)/usr/lib/amanda/killpgrp \
                $(c)/usr/lib/amanda/rundump \
                $(c)/usr/lib/amanda/runtar \
@@ -111,6 +114,9 @@ binary-arch: build
                $(s)/usr/lib/amanda/planner \
                $(s)/usr/sbin/amcheck
        chmod u=srwx,g=rx,o=r \
+               $(c)/usr/lib/amanda/application/amgtar \
+               $(c)/usr/lib/amanda/application/amstar \
+               $(c)/usr/lib/amanda/calcsize \
                $(c)/usr/lib/amanda/killpgrp \
                $(c)/usr/lib/amanda/rundump \
                $(c)/usr/lib/amanda/runtar \
@@ -123,8 +129,9 @@ binary-arch: build
                $(r)/usr/share/lintian/overrides/amanda-common
        install -o root -g root -m 0644 debian/amanda-server.lintian \
                $(s)/usr/share/lintian/overrides/amanda-server
-       dh_makeshlibs -a
+       dh_makeshlibs -pamanda-common --noscripts
        dh_installdeb -a
+       dh_perl -a usr/lib/amanda/perl
        dh_shlibdeps -a -l"debian/amanda-common/usr/lib:debian/amanda-client/usr/lib:debian/amanda-server/usr/lib"
        # strip out the non-versioned amanda-common references, we need
        # the versioned ones in the control file and dupes are ugly...
@@ -140,4 +147,4 @@ source diff:
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: configure build-indep build-arch build clean binary-indep binary-arch binary