Removed generated file from version control.
[debian/gnuradio] / debian / rules
index a0f70f4d7075ecf8c8dc63a34c31221b49d186c9..2bbec0fa4bc4e16b9c103673286e145b3670149e 100755 (executable)
@@ -1,14 +1,4 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-#
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-#
-# Modified to make a template file for a multi-binary package with separated
-# build-arch and build-indep targets  by Bill Allombert 2001
 
 # Uncomment this to turn on verbose mode.
 export DH_VERBOSE=1
@@ -27,7 +17,7 @@ endif
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp configure-stamp extract-stamp install-stamp
 
        if [ -f Makefile ]; \
        then\
@@ -58,7 +48,8 @@ configure-stamp:
                --enable-doxygen --enable-html-docs \
                --sysconfdir=/etc --enable-all-components \
                --disable-gr-audio-osx --disable-gr-audio-windows \
-               --disable-gr-qtgui
+               --disable-gr-qtgui --disable-gcell --disable-gr-gcell \
+               --disable-gr-comedi --disable-usrp2-firmware
        touch configure-stamp
 
 extract: extract-stamp
@@ -90,24 +81,11 @@ install-stamp: build-stamp
          fi; \
        done
 
-       dh_install --sourcedir=debian/tmp --list-missing
+       : # Deposit rule to allow group 'usrp' access to USRP hardware
+       install -m 0644 -D debian/libusrp.udev \
+               debian/tmp/etc/udev/rules.d/40-usrp.rules
 
-#      install -m 0755 debian/usrp.hotplug \
-#              $(CURDIR)/debian/usrp/etc/hotplug.d/usb/
-
-#      cp -r gnuradio-examples/python/* \
-#              debian/gnuradio-examples/usr/share/gnuradio/
-#      find debian/gnuradio-examples -type f -name Makefile\* -exec rm {} \;
-#      find debian/gnuradio-examples -type d -name CVS -exec rm {} \;
-#      find debian/gnuradio-examples -name \*.py -exec chmod +x {} \;
-
-#      mv debian/gnuradio/usr/bin/microtune.py \
-#              debian/gnuradio/usr/bin/microtune
-
-#      mv debian/usrp/usr/bin/usrp_ra_receiver.py \
-#              debian/usrp/usr/bin/usrp_ra_receiver
-#      mv debian/usrp/usr/bin/usrp_psr_receiver.py \
-#              debian/usrp/usr/bin/usrp_psr_receiver
+       dh_install --sourcedir=debian/tmp
        touch $@
 
 
@@ -119,25 +97,11 @@ binary-common:
        dh_testroot
        dh_installchangelogs ChangeLog
        dh_installdocs
-       dh_installexamples
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate     
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
        dh_pycentral
-       dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
        dh_link
        dh_strip
        dh_compress 
-#      dh_movefiles --sourcedir=debian/gnuradio
        dh_fixperms
-#      dh_perl
        dh_makeshlibs
        dh_installdeb
        dh_shlibdeps