Removed generated file from version control.
[debian/gnuradio] / debian / rules
index 92d5bd65a46cf470a482eee8e15ddf340d9e9cc9..2bbec0fa4bc4e16b9c103673286e145b3670149e 100755 (executable)
@@ -1,14 +1,4 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-#
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-#
-# Modified to make a template file for a multi-binary package with separated
-# build-arch and build-indep targets  by Bill Allombert 2001
 
 # Uncomment this to turn on verbose mode.
 export DH_VERBOSE=1
@@ -58,7 +48,8 @@ configure-stamp:
                --enable-doxygen --enable-html-docs \
                --sysconfdir=/etc --enable-all-components \
                --disable-gr-audio-osx --disable-gr-audio-windows \
-               --disable-gr-qtgui
+               --disable-gr-qtgui --disable-gcell --disable-gr-gcell \
+               --disable-gr-comedi --disable-usrp2-firmware
        touch configure-stamp
 
 extract: extract-stamp
@@ -90,12 +81,11 @@ install-stamp: build-stamp
          fi; \
        done
 
-       dh_install --sourcedir=debian/tmp
-
-# FIXME: Ubuntu vs. Debian (below)
-#      install -m 0755 debian/usrp.hotplug \
-#              $(CURDIR)/debian/usrp/etc/hotplug.d/usb/
+       : # Deposit rule to allow group 'usrp' access to USRP hardware
+       install -m 0644 -D debian/libusrp.udev \
+               debian/tmp/etc/udev/rules.d/40-usrp.rules
 
+       dh_install --sourcedir=debian/tmp
        touch $@