oops, not delivering this file any more
[debian/amanda] / debian / rules
index d406bd00aaec0a2f44c62d014690dc2adecc79b0..2aabb1f9ed2ac9dddee43c81b2b70e2d8e82eb89 100755 (executable)
@@ -1,9 +1,6 @@
 #!/usr/bin/make -f
-# debian/rules for amanda using debhelper. GNU copyright 1998 by Bdale Garbee.
-# requires automake 1.2d (from experimental tree)
-
-#      Warning - do *not* use -j on an SMP machine, or the build gets
-#              confused... some sort of race condition in the makefiles?
+# debian/rules for amanda using debhelper
+# Copyright 1998-2009 by Bdale Garbee.  License GPL v2
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -18,23 +15,35 @@ configure-stamp:
        # pick up latest config files provided by autotools-dev
        cp -f /usr/share/misc/config.sub config/config.sub
        cp -f /usr/share/misc/config.guess config/config.guess
-#      automake --foreign
-#      autoconf -l config
+       # do we need --{htmldir,dvidir,pdfdir,psdir} to force subdirectories?
+       # should we re-craft this to use --without-server and --without-client,
+       #       and lose the amanda-common package?
        MAILER=/usr/bin/mail \
-       ./configure --prefix=/usr --bindir=/usr/sbin --mandir=/usr/share/man \
-               --enable-shared\
-               --sysconfdir=/etc --localstatedir=/var/lib \
+       SSH=/usr/bin/ssh \
+       ./configure \
+               --prefix=/usr \
+               --bindir=/usr/sbin \
+               --libexecdir=/usr/lib/amanda \
+               --without-amlibexecdir \
+               --without-amperldir \
+               --sysconfdir=/etc \
+               --sharedstatedir=/var/lib \
+               --localstatedir=/var/lib \
+               --with-user=backup \
+               --with-group=backup  \
+               --with-tcpportrange=50000,50100 \
+               --with-udpportrange=840,860 \
+               --with-debugging=/var/log/amanda \
                --with-gnutar-listdir=/var/lib/amanda/gnutar-lists \
                --with-index-server=localhost \
-               --with-user=backup --with-group=backup  \
-               --with-bsd-security --with-amandahosts \
+               --with-bsd-security \
                --with-smbclient=/usr/bin/smbclient \
-               --with-debugging=/var/log/amanda \
-               --with-dumperdir=/usr/lib/amanda/dumper.d \
-               --with-tcpportrange=50000,50100 --with-udpportrange=840,860 \
-               --with-maxtapeblocksize=256 \
+               --with-amandahosts \
                --with-ssh-security \
-               --with-bsdtcp-security --with-bsdudp-security
+               --with-bsdtcp-security \
+               --with-bsdudp-security \
+               --without-ipv6
+
        touch missing
        touch configure-stamp
 
@@ -110,11 +119,11 @@ binary-arch: build
                $(s)/usr/sbin/amcheck
        install -o root -g root -m 0644 debian/amanda-client.lintian \
                $(c)/usr/share/lintian/overrides/amanda-client
-       install -o root -g root -m 0644 debian/amanda-common.lintian \
-               $(r)/usr/share/lintian/overrides/amanda-common
+#      install -o root -g root -m 0644 debian/amanda-common.lintian \
+#              $(r)/usr/share/lintian/overrides/amanda-common
        install -o root -g root -m 0644 debian/amanda-server.lintian \
                $(s)/usr/share/lintian/overrides/amanda-server
-       dh_makeshlibs -a
+       dh_makeshlibs -pamanda-common --noscripts
        dh_installdeb -a
        dh_shlibdeps -a -l"debian/amanda-common/usr/lib:debian/amanda-client/usr/lib:debian/amanda-server/usr/lib"
        # strip out the non-versioned amanda-common references, we need