Merged r11452:11459 from jcorgan/pmt-gruel into trunk. Trunk passes distcheck.
[debian/gnuradio] / debian / rules
index edabac6fe9945adb8695ef6b2d2ec2bb5a2a2c65..1fc459280b7ca905db8f9983d428d19e9132da68 100755 (executable)
@@ -57,9 +57,9 @@ build-stamp: configure-stamp
        touch $@
 
 extract: extract-stamp
-extract-stamp: build-stamp debian/gen-install-files.sh
+extract-stamp: build-stamp debian/bin/gen-install-files.sh
        dh_testdir
-       debian/gen-install-files.sh 
+       debian/bin/gen-install-files.sh 
        touch $@
 
 install: install-stamp
@@ -79,21 +79,17 @@ install-stamp: extract-stamp debian/control
        done
 
        : # Deposit rule to allow group 'usrp' access to USRP hardware
-       install -m 0644 -D debian/libusrp.udev \
+       install -m 0644 -D debian/custom/libusrp.udev \
                debian/tmp/etc/udev/rules.d/40-usrp.rules
 
        : # Deposit rule to allow group 'usrp' access to USRP2 hardware
-       install -m 0644 -D debian/libusrp2.limits \
+       install -m 0644 -D debian/custom/libusrp2.limits \
                debian/tmp/etc/security/limits.d/libusrp2.limits
 
        : # Install custom grc.conf
-       install -m 0644 -D debian/grc.conf \
+       install -m 0644 -D debian/custom/grc.conf \
                debian/tmp/etc/gnuradio/conf.d/grc.conf
 
-       : # Install custom prefs.py FIXME
-       install -m 0644 -D debian/prefs.py \
-               debian/tmp/usr/lib/python2.6/dist-packages/gnuradio/gr/prefs.py
-
        dh_install --sourcedir=debian/tmp
        touch $@