]> git.gag.com Git - debian/cc1111/blobdiff - debian/rules
patches from Kamal Mostafa <kamal@whence.com> for rules and gcc 4.6.3 issues
[debian/cc1111] / debian / rules
index fc2244c18c0be668548731bf4782c2ebbd5fe395..171c82a56672df9e6e2f7811635800378dfdc144 100755 (executable)
@@ -9,10 +9,10 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 export HOME=$(CURDIR)/build
 
-CFLAGS = `dpkg-buildflags --get CFLAGS`
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
 CFLAGS += -Wall -Wno-comment
-LDFLAGS = `dpkg-buildflags --get LDFLAGS`
-CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
 
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -g -O0
@@ -132,6 +132,12 @@ install-stamp: build
        rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/z80
        rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/ds390
        rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/gbz80
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/include/ds400rom.h
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/include/*390*
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/include/asm/pic
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/include/asm/pic16
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/include/asm/z80
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/include/asm/gbz80
        touch $@
 
 # Must not depend on anything. This is to be called by binary-arch/binary-indep