Merged r6271:6278 from jcorgan/t182 into trunk. Implements ticket:182.
[debian/gnuradio] / configure.ac
index ceea98c04a9b8172d355ef4bd05ce5ba55ce676a..e8a4efe2f7941aec448ce938fb1eb78ae93be63f 100644 (file)
@@ -4,7 +4,7 @@ dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -25,6 +25,9 @@ AC_CANONICAL_TARGET([])
 AM_INIT_AUTOMAKE(gnuradio,3.0svn)
 AC_CONFIG_SRCDIR([gnuradio-core/src/lib/runtime/gr_vmcircbuf.cc])
 
+DEFINES=""
+AC_SUBST(DEFINES)
+
 dnl Remember if the user explicity set CXXFLAGS
 if test -n "${CXXFLAGS}"; then
   user_set_cxxflags=yes
@@ -46,7 +49,16 @@ if test "$user_set_cxxflags" != yes; then
   autoconf_default_CXXFLAGS="$CXXFLAGS"
   CXXFLAGS=""
   if test "$GXX" = yes; then
-    swig_CXXFLAGS="-g1 -O1"
+    case "$host_cpu" in
+       powerpc*)
+          # "-O1" is broken on the PPC for some reason
+          # (at least as of g++ 4.1.1)
+          swig_CXXFLAGS="-g1 -O2"
+       ;;
+       *) 
+       swig_CXXFLAGS="-g1 -O1"
+       ;;
+    esac
   fi
 fi
 AC_SUBST(autoconf_default_CXXFLAGS)
@@ -99,7 +111,7 @@ AC_HEADER_STDC
 AC_HEADER_SYS_WAIT
 AC_CHECK_HEADERS(fcntl.h limits.h strings.h time.h sys/ioctl.h sys/time.h unistd.h)
 AC_CHECK_HEADERS(linux/ppdev.h sys/mman.h sys/select.h sys/types.h)
-AC_CHECK_HEADERS(sys/resource.h stdint.h sched.h signal.h)
+AC_CHECK_HEADERS(sys/resource.h stdint.h sched.h signal.h sys/syscall.h)
 
 dnl Checks for typedefs, structures, and compiler characteristics.
 AC_C_CONST
@@ -115,7 +127,8 @@ AC_FUNC_SETVBUF_REVERSED
 AC_FUNC_VPRINTF
 AC_CHECK_FUNCS([mmap select socket strcspn strerror strspn getpagesize sysconf])
 AC_CHECK_FUNCS([snprintf gettimeofday nanosleep sched_setscheduler])
-AC_CHECK_FUNCS([modf sqrt sigaction sigprocmask])
+AC_CHECK_FUNCS([modf sqrt sigaction sigprocmask pthread_sigmask])
+AC_CHECK_FUNCS([sched_setaffinity])
 
 AC_CHECK_LIB(m, sincos, [AC_DEFINE([HAVE_SINCOS],[1],[Define to 1 if your system has `sincos'.])])
 AC_CHECK_LIB(m, sincosf,[AC_DEFINE([HAVE_SINCOSF],[1],[Define to 1 if your system has `sincosf'.])])
@@ -173,9 +186,6 @@ dnl Define where to find boost includes
 dnl defines BOOST_CFLAGS
 GR_REQUIRE_BOOST_INCLUDES
 
-DEFINES=""
-AC_SUBST(DEFINES)
-
 dnl Component specific configuration
 dnl The order of the GR_ macros determines the order of compilation
 AC_ARG_ENABLE(
@@ -184,7 +194,10 @@ AC_ARG_ENABLE(
 )
 
 build_dirs="config"
+GRC_OMNITHREAD                 dnl must come before gnuradio-core and mblock
 GRC_GNURADIO_CORE
+GRC_PMT
+GRC_MBLOCK                     dnl this must come after GRC_PMT
 GRC_USRP
 GRC_GR_USRP                    dnl this must come after GRC_USRP
 GRC_GR_AUDIO_ALSA
@@ -195,19 +208,17 @@ GRC_GR_AUDIO_PORTAUDIO
 GRC_GR_AUDIO_WINDOWS
 GRC_GR_ATSC
 GRC_GR_COMEDI
-GRC_GR_ERROR_CORRECTING_CODES
+GRC_GR_CVSD_VOCODER
 GRC_GR_GSM_FR_VOCODER
 GRC_GR_PAGER
-GRC_GR_RADAR
+GRC_GR_RADAR_MONO
 GRC_GR_RADIO_ASTRONOMY
 GRC_GR_TRELLIS
 GRC_GR_VIDEO_SDL
+GRC_GR_QTGUI
 GRC_GR_WXGUI
-GRC_PMT
-GRC_MBLOCK                     dnl this must come after GRC_PMT
-GRC_EZDOP              
-GRC_GR_EZDOP                   dnl this must come after GRC_EZDOP
-GRC_GR_RDF
+GRC_GR_SOUNDER                 dnl this must come after GRC_USRP
+GRC_GR_UTILS
 GRC_GNURADIO_EXAMPLES          dnl must come last
 
 # Each component is now either to be built, was skipped, or failed dependencies