Merged r6271:6278 from jcorgan/t182 into trunk. Implements ticket:182.
[debian/gnuradio] / configure.ac
index bdb1eae8f1a3ac2440c56acc3d89b5250f93f0f5..e8a4efe2f7941aec448ce938fb1eb78ae93be63f 100644 (file)
@@ -49,14 +49,11 @@ if test "$user_set_cxxflags" != yes; then
   autoconf_default_CXXFLAGS="$CXXFLAGS"
   CXXFLAGS=""
   if test "$GXX" = yes; then
-    case "$host_os" in
-       darwin*)
-       if test "$host_cpu" = i386; then
-          swig_CXXFLAGS="-g1 -O1"
-       else
-          # "-O1" breaks PPC-OSX for some reason
+    case "$host_cpu" in
+       powerpc*)
+          # "-O1" is broken on the PPC for some reason
+          # (at least as of g++ 4.1.1)
           swig_CXXFLAGS="-g1 -O2"
-       fi      
        ;;
        *) 
        swig_CXXFLAGS="-g1 -O1"
@@ -221,6 +218,7 @@ GRC_GR_VIDEO_SDL
 GRC_GR_QTGUI
 GRC_GR_WXGUI
 GRC_GR_SOUNDER                 dnl this must come after GRC_USRP
+GRC_GR_UTILS
 GRC_GNURADIO_EXAMPLES          dnl must come last
 
 # Each component is now either to be built, was skipped, or failed dependencies