Applied patch in ticket:59 by Don Ward. Updates waterfallsink.py to use
[debian/gnuradio] / configure.ac
index 9da583cedf88c7cf752029ce4b0a6e952e811ff8..add98a53705a5ecd3703d8fec63deb507aca73a9 100644 (file)
@@ -23,6 +23,7 @@ AM_CONFIG_HEADER(config.h)
 AC_CANONICAL_HOST
 AC_CANONICAL_TARGET([])
 AM_INIT_AUTOMAKE(gnuradio,2.8svn)
+AC_CONFIG_SRCDIR([gnuradio-core/src/lib/runtime/gr_vmcircbuf.cc])
 
 GR_X86_64              dnl check for lib64 suffix
 LF_CONFIGURE_CC
@@ -34,6 +35,7 @@ GR_PROG_AS
 AC_PROG_LN_S
 AC_PROG_MAKE_SET
 AC_PROG_INSTALL
+AC_PATH_PROG([RM_PROG], [rm])
 
 AC_LIBTOOL_WIN32_DLL
 dnl AC_DISABLE_SHARED  dnl don't build shared libraries
@@ -45,6 +47,9 @@ GR_FORTRAN
 GR_NO_UNDEFINED                dnl do we need the -no-undefined linker flag
 GR_SCRIPTING
 
+AC_CHECK_PROG([XMLTO],[xmlto],[yes],[])
+AM_CONDITIONAL([HAS_XMLTO], [test x$XMLTO = xyes])
+
 dnl Checks for libraries.
 AC_CHECK_LIB(socket,socket)
 
@@ -148,7 +153,12 @@ AC_SUBST(DEFINES)
 
 dnl Component specific configuration
 dnl The order of the GR_ macros determines the order of compilation
-subdirs="config"
+AC_ARG_ENABLE(
+    [all-components],
+    [  --enable-all-components Build all components or stop on failed dependencies]
+)
+
+build_dirs="config"
 GRC_GNURADIO_CORE
 GRC_GNURADIO_EXAMPLES
 GRC_USRP
@@ -156,55 +166,59 @@ GRC_GR_USRP                       dnl this must come after GRC_USRP
 GRC_GR_AUDIO_ALSA
 GRC_GR_AUDIO_JACK
 GRC_GR_AUDIO_OSS
-GRC_GR_AUDIO_OSX               dnl ***NOT TESTED***
-GRC_GR_AUDIO_PORTAUDIO         dnl ***NOT TESTED***
-GRC_GR_AUDIO_WINDOWS           dnl ***NOT TESTED***
+GRC_GR_AUDIO_OSX
+GRC_GR_AUDIO_PORTAUDIO
+GRC_GR_AUDIO_WINDOWS
 GRC_GR_ATSC
 GRC_GR_COMEDI
-GRC_GR_ERROR_CORRECTING_CODES  dnl disabled until fix for ticket:25
+GRC_GR_ERROR_CORRECTING_CODES
 GRC_GR_GSM_FR_VOCODER
 GRC_GR_RADAR
 GRC_GR_RADIO_ASTRONOMY
+GRC_GR_TRELLIS
 GRC_GR_VIDEO_SDL
 GRC_GR_WXGUI
 GRC_PMT
-GRC_GR_TRELLIS
-GRC_EZDOP
+GRC_MBLOCK                     dnl this must come after GRC_PMT
+GRC_EZDOP              
 GRC_GR_EZDOP                   dnl this must come after GRC_EZDOP
 
-dnl Has list of successfully configured components
-AC_SUBST([subdirs],$subdirs)
-AC_SUBST([failed_subdirs], $failed)
+# Each component is now either to be built, was skipped, or failed dependencies
+AC_SUBST([build_dirs], [$build_dirs])
+AC_SUBST([skipped_dirs], [$skipped_dirs])
  
 AC_CONFIG_FILES([\
-         Makefile \
-         config/Makefile
+    Makefile \
+    run_tests.sh
+    config/Makefile
 ])
 
+dnl run_tests.sh is created from run_tests.in.sh.  Make it executable.
+AC_CONFIG_COMMANDS([run_tests_build], [chmod +x run_tests.sh])
+
 AC_OUTPUT
 
 echo
-echo "*******************************************************************"
+echo "*********************************************************************"
 echo The following GNU Radio components have been successfully configured:
 echo 
-for dir in $subdirs
+for dir in $build_dirs
 do
     echo $dir
 done
 echo
-if test "$failed" != ""; then
-    echo However, the following components did not configure successfully due to 
-    echo missing dependencies:
+echo You my now run the 'make' command to build these components.
+echo
+if test "$skipped_dirs" != ""; then
+    echo "*********************************************************************"
+    echo The following components were skipped either because you asked not
+    echo to build them or they didn\'t pass configuration checks:
     echo
-    for dir in $failed
+    for dir in $skipped_dirs
     do
         echo $dir
     done
     echo
-    echo You may still run the 'make' command to build the successfully configured
-    echo components.
+    echo These components will not be built.
     echo
-    #exit 1
 fi
-echo You my now run the 'make' command to build these packages.
-echo