Merged r9433:9527 from features/gr-usrp2 into trunk. Adds usrp2 and gr-usrp2 top...
[debian/gnuradio] / configure.ac
index 8c1ceccd4b1b5e55fc78504412aa47b6140ab957..4b581a16bbc288ae9798e69554dadbdf4629b776 100644 (file)
@@ -50,16 +50,15 @@ dnl the output of swig use use -O1 if we're using g++.
 dnl See Makefile.common for the rest of the magic.
 if test "$user_set_cxxflags" != yes; then
   autoconf_default_CXXFLAGS="$CXXFLAGS"
-  CXXFLAGS=""
   if test "$GXX" = yes; then
     case "$host_cpu" in
        powerpc*)
           dnl "-O1" is broken on the PPC for some reason
           dnl (at least as of g++ 4.1.1)
-          swig_CXXFLAGS="-g1 -O2"
+          swig_CXXFLAGS="-g1 -O2 -Wno-strict-aliasing -Wno-parentheses"
        ;;
        *) 
-       swig_CXXFLAGS="-g -O1"
+       swig_CXXFLAGS="-g -O1 -Wno-strict-aliasing -Wno-parentheses"
        ;;
     esac
   fi
@@ -77,7 +76,6 @@ fi
 export PKG_CONFIG_PATH
 
 
-LF_SET_WARNINGS
 GR_SET_GPROF
 GR_SET_PROF
 AM_PROG_AS
@@ -130,6 +128,7 @@ AC_CHECK_HEADERS(linux/ppdev.h dev/ppbus/ppi.h sys/mman.h sys/select.h sys/types
 AC_CHECK_HEADERS(sys/resource.h stdint.h sched.h signal.h sys/syscall.h)
 AC_CHECK_HEADERS(netinet/in.h)
 AC_CHECK_HEADERS(windows.h)
+AC_CHECK_HEADERS(vec_types.h)
 
 dnl Checks for typedefs, structures, and compiler characteristics.
 AC_C_CONST
@@ -246,7 +245,7 @@ GR_SUBVERSION
 dnl Component specific configuration
 dnl The order of the GR_ macros determines the order of compilation
 dnl For -any- checks on $enable_all_components
-dnl use the following guildlines:
+dnl use the following guidelines:
 dnl   yes : --enable-all-components was specified, so error out if any
 dnl         components do not pass configuration checks.
 dnl   no  : --disable-all-components was specified, so try to build the
@@ -273,7 +272,9 @@ GRC_GNURADIO_CORE
 GRC_PMT
 GRC_MBLOCK                     dnl this must come after GRC_PMT
 GRC_USRP
+GRC_USRP2
 GRC_GR_USRP                    dnl this must come after GRC_USRP
+GRC_GR_USRP2
 GRC_GR_GCELL                   dnl this must come after GRC_GCELL and GRC_GNURADIO_CORE
 GRC_GR_MSDD6000        
 GRC_GR_AUDIO_ALSA
@@ -295,7 +296,8 @@ GRC_GR_VIDEO_SDL
 GRC_GR_WXGUI
 GRC_GR_SOUNDER                 dnl this must come after GRC_USRP
 GRC_GR_UTILS                    dnl this must come after GRC_GR_WXGUI
-GRC_GNURADIO_EXAMPLES          dnl must come last
+GRC_GNURADIO_EXAMPLES          dnl must come after all GRC_GR_*
+GRC_GRC
 
 # Each component is now either to be built, was skipped, will be
 # included from pre-installed libraries and includes, or failed
@@ -327,6 +329,11 @@ AC_CONFIG_FILES([\
 dnl run_tests.sh is created from run_tests.sh.in .  Make it executable.
 AC_CONFIG_COMMANDS([run_tests_build], [chmod +x run_tests.sh])
 
+dnl Enable warnings as the last thing before generating output, since
+dnl this may add -Werror to CFLAGS which can cause various configure
+dnl checks to fail.
+LF_SET_WARNINGS
+
 AC_OUTPUT
 
 echo