Reenable GRC component
[debian/gnuradio] / configure.ac
index 74dde0dd12c1af98223ba2c241a24e456d33710c..4b581a16bbc288ae9798e69554dadbdf4629b776 100644 (file)
@@ -28,14 +28,6 @@ AC_CANONICAL_TARGET
 
 AM_INIT_AUTOMAKE(gnuradio,3.1svn)
 
-dnl add ${prefix}/lib/pkgconfig to the head of the PKG_CONFIG_PATH
-if test [x]${PKG_CONFIG_PATH} = x; then
-    PKG_CONFIG_PATH=${prefix}/lib/pkgconfig
-else
-    PKG_CONFIG_PATH=${prefix}/lib/pkgconfig:${PKG_CONFIG_PATH}
-fi
-export PKG_CONFIG_PATH
-
 DEFINES=""
 AC_SUBST(DEFINES)
 
@@ -44,9 +36,9 @@ if test -n "${CXXFLAGS}"; then
   user_set_cxxflags=yes
 fi
 
-GR_X86_64              dnl check for lib64 suffix
 LF_CONFIGURE_CC
 LF_CONFIGURE_CXX
+GR_LIB64               dnl check for lib64 suffix after choosing compilers
 
 dnl The three macros above are known to override CXXFLAGS if the user
 dnl didn't specify them.  Though I'm sure somebody thought this was
@@ -58,16 +50,15 @@ dnl the output of swig use use -O1 if we're using g++.
 dnl See Makefile.common for the rest of the magic.
 if test "$user_set_cxxflags" != yes; then
   autoconf_default_CXXFLAGS="$CXXFLAGS"
-  CXXFLAGS=""
   if test "$GXX" = yes; then
     case "$host_cpu" in
        powerpc*)
           dnl "-O1" is broken on the PPC for some reason
           dnl (at least as of g++ 4.1.1)
-          swig_CXXFLAGS="-g1 -O2"
+          swig_CXXFLAGS="-g1 -O2 -Wno-strict-aliasing -Wno-parentheses"
        ;;
        *) 
-       swig_CXXFLAGS="-g -O1"
+       swig_CXXFLAGS="-g -O1 -Wno-strict-aliasing -Wno-parentheses"
        ;;
     esac
   fi
@@ -75,7 +66,16 @@ fi
 AC_SUBST(autoconf_default_CXXFLAGS)
 AC_SUBST(swig_CXXFLAGS)
 
-LF_SET_WARNINGS
+
+dnl add ${prefix}/lib${gr_libdir_suffix}/pkgconfig to the head of the PKG_CONFIG_PATH
+if test x${PKG_CONFIG_PATH} = x; then
+    PKG_CONFIG_PATH=${prefix}/lib${gr_libdir_suffix}/pkgconfig
+else
+    PKG_CONFIG_PATH=${prefix}/lib${gr_libdir_suffix}/pkgconfig:${PKG_CONFIG_PATH}
+fi
+export PKG_CONFIG_PATH
+
+
 GR_SET_GPROF
 GR_SET_PROF
 AM_PROG_AS
@@ -88,7 +88,7 @@ AC_LIBTOOL_WIN32_DLL
 dnl AC_DISABLE_SHARED  dnl don't build shared libraries
 AC_ENABLE_SHARED       dnl do build shared libraries
 AC_DISABLE_STATIC      dnl don't build static libraries
-AC_PROG_LIBTOOL
+m4_ifdef([LT_INIT],[LT_INIT],[AC_PROG_LIBTOOL])
 GR_FORTRAN
 
 GR_NO_UNDEFINED                dnl do we need the -no-undefined linker flag
@@ -100,11 +100,12 @@ AM_CONDITIONAL([HAS_XMLTO], [test x$XMLTO = xyes])
 dnl Checks for libraries.
 AC_CHECK_LIB(socket,socket)
 
-dnl check for threads (mandatory)
+dnl check for omnithreads (will soon be removed)
 GR_OMNITHREAD
-CFLAGS="${CFLAGS} $PTHREAD_CFLAGS"
-CXXFLAGS="${CXXFLAGS} $PTHREAD_CFLAGS"
+CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+CXXFLAGS="$CXXFLAGS $PTHREAD_CFLAGS"
 
+dnl Set the c++ compiler that we use for the build system when cross compiling
 if test x$CXX_FOR_BUILD = x
 then
   if test x$cross_compiling = xno; then
@@ -113,7 +114,6 @@ then
     CXX_FOR_BUILD=g++
   fi
 fi
-
 AC_SUBST(CXX_FOR_BUILD)
 
 dnl Check for SysV shm (mandatory)
@@ -128,13 +128,15 @@ AC_CHECK_HEADERS(linux/ppdev.h dev/ppbus/ppi.h sys/mman.h sys/select.h sys/types
 AC_CHECK_HEADERS(sys/resource.h stdint.h sched.h signal.h sys/syscall.h)
 AC_CHECK_HEADERS(netinet/in.h)
 AC_CHECK_HEADERS(windows.h)
+AC_CHECK_HEADERS(vec_types.h)
 
 dnl Checks for typedefs, structures, and compiler characteristics.
 AC_C_CONST
 AC_C_INLINE
 AC_TYPE_SIZE_T
 AC_HEADER_TIME
-AC_C_BIGENDIAN
+AC_C_BIGENDIAN([GR_ARCH_BIGENDIAN=1],[GR_ARCH_BIGENDIAN=0])
+AC_SUBST(GR_ARCH_BIGENDIAN)
 AC_STRUCT_TM
 
 dnl Checks for library functions.
@@ -203,15 +205,39 @@ PKG_CHECK_EXISTS(cppunit,
   [AM_PATH_CPPUNIT([1.9.14],[],
                [AC_MSG_ERROR([GNU Radio requires cppunit.  Stop])])])
 
+CPPUNIT_INCLUDES=$CPPUNIT_CFLAGS
+AC_SUBST(CPPUNIT_INCLUDES)
+
 dnl see if GUILE is installed
 AC_PATH_PROG(GUILE,guile)
 
-CPPUNIT_INCLUDES=$CPPUNIT_CFLAGS
-AC_SUBST(CPPUNIT_INCLUDES)
+dnl
+dnl We require the boost headers, thread lib and date_time lib.
+dnl AX_BOOST_BASE finds the headers and the lib dir (-L<foo>)
+dnl
+dnl calls AC_SUBST(BOOST_CPPFLAGS), AC_SUBST(BOOST_LDFLAGS) and defines HAVE_BOOST
+AX_BOOST_BASE([1.35])
+
+dnl calls AC_SUBST(BOOST_THREAD_LIB), AC_SUBST(BOOST_CXXFLAGS) and defines HAVE_BOOST_THREAD
+AX_BOOST_THREAD
+CXXFLAGS="$CXXFLAGS $BOOST_CXXFLAGS"       dnl often picks up a -pthread or something similar
+CFLAGS="$CFLAGS $BOOST_CXXFLAGS"           dnl often picks up a -pthread or something similar
+
+dnl
+dnl all the rest of these call AC_SUBST(BOOST_<foo>_LIB) and define HAVE_BOOST_<foo>
+dnl
+AX_BOOST_DATE_TIME
+dnl AX_BOOST_FILESYSTEM
+dnl AX_BOOST_IOSTREAMS
+dnl AX_BOOST_PROGRAM_OPTIONS
+dnl AX_BOOST_REGEX
+dnl AX_BOOST_SERIALIZATION
+dnl AX_BOOST_SIGNALS
+dnl AX_BOOST_SYSTEM
+dnl AX_BOOST_TEST_EXEC_MONITOR
+dnl AX_BOOST_UNIT_TEST_FRAMEWORK
+dnl AX_BOOST_WSERIALIZATION
 
-dnl Define where to find boost includes
-dnl defines BOOST_CFLAGS
-GR_REQUIRE_BOOST_INCLUDES
 
 dnl If this is being done from a subversion tree, create variables
 GR_SUBVERSION
@@ -219,7 +245,7 @@ GR_SUBVERSION
 dnl Component specific configuration
 dnl The order of the GR_ macros determines the order of compilation
 dnl For -any- checks on $enable_all_components
-dnl use the following guildlines:
+dnl use the following guidelines:
 dnl   yes : --enable-all-components was specified, so error out if any
 dnl         components do not pass configuration checks.
 dnl   no  : --disable-all-components was specified, so try to build the
@@ -239,15 +265,18 @@ AC_ARG_ENABLE(
 )
 
 build_dirs="config"
+GRC_GRUEL                       dnl must come first
 GRC_OMNITHREAD                 dnl must come before gnuradio-core and mblock
-GRC_PMT
-GRC_MBLOCK                     dnl this must come after GRC_PMT
 GRC_GCELL
 GRC_GNURADIO_CORE
+GRC_PMT
+GRC_MBLOCK                     dnl this must come after GRC_PMT
 GRC_USRP
+GRC_USRP2
 GRC_GR_USRP                    dnl this must come after GRC_USRP
+GRC_GR_USRP2
 GRC_GR_GCELL                   dnl this must come after GRC_GCELL and GRC_GNURADIO_CORE
-GRC_GR_MSDD6000
+GRC_GR_MSDD6000        
 GRC_GR_AUDIO_ALSA
 GRC_GR_AUDIO_JACK
 GRC_GR_AUDIO_OSS
@@ -267,7 +296,8 @@ GRC_GR_VIDEO_SDL
 GRC_GR_WXGUI
 GRC_GR_SOUNDER                 dnl this must come after GRC_USRP
 GRC_GR_UTILS                    dnl this must come after GRC_GR_WXGUI
-GRC_GNURADIO_EXAMPLES          dnl must come last
+GRC_GNURADIO_EXAMPLES          dnl must come after all GRC_GR_*
+GRC_GRC
 
 # Each component is now either to be built, was skipped, will be
 # included from pre-installed libraries and includes, or failed
@@ -299,6 +329,11 @@ AC_CONFIG_FILES([\
 dnl run_tests.sh is created from run_tests.sh.in .  Make it executable.
 AC_CONFIG_COMMANDS([run_tests_build], [chmod +x run_tests.sh])
 
+dnl Enable warnings as the last thing before generating output, since
+dnl this may add -Werror to CFLAGS which can cause various configure
+dnl checks to fail.
+LF_SET_WARNINGS
+
 AC_OUTPUT
 
 echo