Added copyright header
[debian/gnuradio] / config / usrp_libusb.m4
index 107144e338842d8807e70e0c1759d238df4069a7..9a019a46071f0294fd6526b2892858867c0a2bb8 100644 (file)
@@ -75,13 +75,33 @@ AC_DEFUN([USRP_LIBUSB], [
 
         echo creating $outfile
         cat > $tmpfile << _EOF_
-/*  -*- Mode: C++ -*-
-* --------------------------------------------------------------------
-* DO NOT EDIT THIS FILE!  It has been automatically generated
-* from:    configure.in and `echo $outfile|$dirname`.in
-* on host: `(hostname || uname -n) 2>/dev/null | sed 1q`
-* --------------------------------------------------------------------
-*/
+ /*  -*- Mode: C++ -*-
+ * --------------------------------------------------------------------
+ * DO NOT EDIT THIS FILE!  It has been automatically generated
+ * from:    configure.in and `echo $outfile|$dirname`.in
+ * on host: `(hostname || uname -n) 2>/dev/null | sed 1q`
+ * --------------------------------------------------------------------
+ *
+ * Copyright 2005 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 3, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
 
 _EOF_
         echo "#ifndef _`echo $outfile | $dirname | tr a-z. A-Z_`_" >> $tmpfile
@@ -108,14 +128,17 @@ _EOF_
         if test x$have_libusb1 = xno; then
           echo 'struct usb_device;'>> $tmpfile
           echo 'struct usb_dev_handle;'>> $tmpfile
-          echo 'typedef struct usb_device libusb_device;' >> $tmpfile
-          echo 'typedef struct usb_dev_handle libusb_device_handle;' >> $tmpfile
+          echo 'struct usb_device_descriptor;' >> $tmpfile
+          echo 'typedef usb_device libusb_device;' >> $tmpfile
+          echo 'typedef usb_dev_handle libusb_device_handle;' >> $tmpfile
+          echo 'typedef usb_device_descriptor libusb_device_descriptor;' >> $tmpfile
           echo >> $tmpfile
         fi
 
         if test x$have_libusb1 = xyes; then
           echo 'struct libusb_device;' >> $tmpfile
           echo 'struct libusb_device_handle;' >> $tmpfile
+          echo 'struct libusb_device_descriptor;' >> $tmpfile
           echo >> $tmpfile
         fi
 
@@ -130,9 +153,9 @@ _EOF_
       have_libusb1=$have_libusb1
     ])
 
-      AC_SUBST(USB_LIBS)
-      ifelse([$1], , :, [$1])
+    AC_SUBST(USB_LIBS)
+    ifelse([$2], , :, [$2])
   else
-      ifelse([$2], , :, [$2])
+    ifelse([$3], , :, [$3])
   fi
 ])