make maintainer-clean removes these, and we want a clean orig.tar.gz
[debian/gnuradio] / config / grc_usrp2.m4
index ec88ab3453a639ef614e7f104f6af73b92562b2e..701b100ad98a3c7e5f91c2eb8870644ed146aa33 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2008 Free Software Foundation, Inc.
+dnl Copyright 2008,2010 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -20,9 +20,11 @@ dnl Boston, MA 02110-1301, USA.
 AC_DEFUN([GRC_USRP2],[
     GRC_ENABLE(usrp2)
 
-    dnl Don't do usrp if omnithread or gruel is skipped
+    dnl firmware uses a subsidiary configure.ac
+    AC_CONFIG_SUBDIRS([usrp2/firmware])
+
+    dnl Don't do usrp if gruel is skipped
     GRC_CHECK_DEPENDENCY(usrp2, gruel)
-    GRC_CHECK_DEPENDENCY(usrp2, omnithread)
 
     dnl USRP2 host code only works on Linux at the moment
     AC_MSG_CHECKING([whether host_os is linux*])
@@ -42,16 +44,6 @@ AC_DEFUN([GRC_USRP2],[
     dnl   yes  : if the --enable code passed muster and all dependencies are met
     dnl   no   : otherwise
     if test $passed = yes; then
-       dnl Only do firmware if mb-gcc can be found
-       AC_CHECK_PROG([MB_GCC],[mb-gcc],[yes],[no])
-       if test $MB_GCC = yes; then
-           dnl Adds usrp2/firmware to $(subdirs), hierarchical build
-           AC_CONFIG_SUBDIRS([usrp2/firmware])
-       else
-           AC_MSG_WARN([usrp2/firmware is not being built])
-       fi
-       AM_CONDITIONAL([BUILDING_USRP2_FIRMWARE],[test $MB_GCC = yes])
-
        dnl Needed for usrp2_socket_opener
        AC_CHECK_HEADERS(arpa/inet.h byteswap.h linux/if_packet.h sys/socket.h sys/un.h)
        AC_CHECK_MEMBERS([struct msghdr.msg_control,