Merged grc developer branch r10679:10938
[debian/gnuradio] / config / grc_usrp.m4
index f810748ab6617c8dbad7a6a2ca21011754999c3b..3b8bb28f4e6bc004642e19579c3badf15a0271b7 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006,2007,2008 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2007,2008,2009 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -58,10 +58,11 @@ AC_DEFUN([GRC_USRP],[
     if test $passed != with; then
        dnl how and where to find INCLUDES and LA
        usrp_INCLUDES="-I\${abs_top_srcdir}/usrp/host/lib/legacy \
-               -I\${abs_top_srcdir}/usrp/firmware/include"
+               -I\${abs_top_srcdir}/usrp/firmware/include \
+               -I\${abs_top_builddir}/usrp/host/lib/legacy"
         usrp_LA="\${abs_top_builddir}/usrp/host/lib/legacy/libusrp.la"
        usrp_inband_INCLUDES="-I\${abs_top_srcdir}/usrp/host/lib/inband"
-       usrp_inband_LA="\${abs_top_builddir}/usrp/host/lib/inband/libusrp_inband.la"
+       usrp_inband_LA="\${abs_top_builddir}/usrp/host/lib/inband/libusrp-inband.la"
     fi
 
     dnl Include the usrp-inband INCLUDES and LA
@@ -106,6 +107,8 @@ AC_DEFUN([GRC_USRP],[
         usrp/firmware/src/usrp2/Makefile \
         usrp/fpga/Makefile \
         usrp/fpga/rbf/Makefile \
+        usrp/fpga/rbf/rev2/Makefile \
+        usrp/fpga/rbf/rev4/Makefile \
     ])
 
     GRC_BUILD_CONDITIONAL(usrp)