Merged r11377:11390 from jcorgan/usrp-headers in to trunk.
[debian/gnuradio] / config / grc_usrp.m4
index 3b8bb28f4e6bc004642e19579c3badf15a0271b7..14c646081c3fcfe8b813344c9a5df92a1086eb6f 100644 (file)
@@ -20,12 +20,10 @@ dnl Boston, MA 02110-1301, USA.
 AC_DEFUN([GRC_USRP],[
     GRC_ENABLE(usrp)
 
-    GRC_WITH(usrp, [GRC_WITH_PKG_CONFIG_CHECK(usrp-inband)])
+    GRC_WITH(usrp)
 
-    dnl Don't do usrp if omnithread, mblock, or pmt skipped
+    dnl Don't do usrp if omnithread skipped
     GRC_CHECK_DEPENDENCY(usrp, omnithread)
-    GRC_CHECK_DEPENDENCY(usrp, mblock)
-    GRC_CHECK_DEPENDENCY(usrp, pmt)
 
     dnl Make sure the fast usb technique is set, OS dependent.
     dnl This is always performed, since it puts out CLI flags.
@@ -46,9 +44,6 @@ AC_DEFUN([GRC_USRP],[
         AC_CHECK_FUNCS([getrusage sched_setscheduler pthread_setschedparam])
         AC_CHECK_FUNCS([sigaction snprintf])
 
-       dnl Don't do usrp if guile not available (inband requires it)
-       GRC_CHECK_GUILE(usrp)
-
        dnl Make sure libusb is installed; required for legacy USB
         USRP_LIBUSB([],[passed=no;AC_MSG_RESULT([Unable to find dependency libusb.])])
 
@@ -57,20 +52,14 @@ AC_DEFUN([GRC_USRP],[
     fi
     if test $passed != with; then
        dnl how and where to find INCLUDES and LA
-       usrp_INCLUDES="-I\${abs_top_srcdir}/usrp/host/lib/legacy \
-               -I\${abs_top_srcdir}/usrp/firmware/include \
-               -I\${abs_top_builddir}/usrp/host/lib/legacy"
-        usrp_LA="\${abs_top_builddir}/usrp/host/lib/legacy/libusrp.la"
-       usrp_inband_INCLUDES="-I\${abs_top_srcdir}/usrp/host/lib/inband"
-       usrp_inband_LA="\${abs_top_builddir}/usrp/host/lib/inband/libusrp-inband.la"
+       usrp_INCLUDES=" \
+               -I\${abs_top_srcdir}/usrp/host/include \
+               -I\${abs_top_builddir}/usrp/host/include \
+               -I\${abs_top_srcdir}/usrp/firmware/include"
+        usrp_LA="\${abs_top_builddir}/usrp/host/lib/libusrp.la"
     fi
 
-    dnl Include the usrp-inband INCLUDES and LA
-    AC_SUBST(usrp_inband_INCLUDES)
-    AC_SUBST(usrp_inband_LA)
-
-    dnl There are 2 pkg-config files (usrp, and usrp-inband); the one
-    dnl for usrp requires omnithread for Darwin only.  Create a variable
+    dnl There pkg-config file for usrp requires omnithread for Darwin only.  Create a variable
     dnl for just the usrp.pc.in case.
     case "$host_os" in
       darwin*)
@@ -85,20 +74,18 @@ AC_DEFUN([GRC_USRP],[
     AC_CONFIG_FILES([ \
        usrp/Makefile \
        usrp/usrp.pc \
-       usrp/usrp-inband.pc \
         usrp/usrp.iss \
         usrp/doc/Doxyfile \
         usrp/doc/Makefile \
         usrp/doc/other/Makefile \
         usrp/host/Makefile \
+       usrp/host/include/Makefile \
+       usrp/host/include/usrp/Makefile \
         usrp/host/misc/Makefile \
         usrp/host/lib/Makefile \
-        usrp/host/lib/inband/Makefile \
-        usrp/host/lib/legacy/Makefile \
-        usrp/host/lib/legacy/std_paths.h \
+        usrp/host/lib/std_paths.h \
         usrp/host/swig/Makefile \
         usrp/host/apps/Makefile \
-        usrp/host/apps-inband/Makefile \
         usrp/firmware/Makefile \
         usrp/firmware/include/Makefile \
         usrp/firmware/lib/Makefile \