make maintainer-clean removes these, and we want a clean orig.tar.gz
[debian/gnuradio] / config / grc_pmt.m4
index 5e2487190f0589655028bb82f49908de2a0c8b63..8e0a58bcad2477c875d76672fae89501aac5a1fe 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -18,25 +18,37 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_PMT],[
-    GRC_ENABLE([pmt])
+    GRC_ENABLE(pmt)
+    GRC_WITH(pmt)
 
-    AC_CONFIG_FILES([\
-       pmt/Makefile \
-       pmt/doc/Makefile \
-       pmt/src/Makefile \
-       pmt/src/lib/Makefile \
-       pmt/src/scheme/Makefile \
-       pmt/src/scheme/gnuradio/Makefile \
-    ])
+    dnl Don't do pmt if omnithread skipped
+    GRC_CHECK_DEPENDENCY(pmt, omnithread)
 
-    passed=yes
-    AC_PATH_PROG(GUILE,guile)
-    if test "$GUILE" = "" ; then
-      AC_MSG_RESULT([Component pmt requires guile, which was not found.])
-      passed=no
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+       dnl Don't do pmt if guile not available
+       GRC_CHECK_GUILE(pmt)
+    fi
+    if test $passed != with; then
+       dnl how and where to find INCLUDES and LA
+       pmt_INCLUDES="-I\${abs_top_srcdir}/pmt/src/lib"
+        pmt_LA="\${abs_top_builddir}/pmt/src/lib/libpmt.la"
     fi
 
-    GRC_BUILD_CONDITIONAL([pmt],[
+    AC_CONFIG_FILES([\
+        pmt/Makefile \
+        pmt/pmt.pc \
+        pmt/doc/Makefile \
+        pmt/src/Makefile \
+        pmt/src/lib/Makefile \
+        pmt/src/scheme/Makefile \
+        pmt/src/scheme/gnuradio/Makefile \
+    ])
+
+    GRC_BUILD_CONDITIONAL(pmt,[
         dnl run_tests is created from run_tests.in.  Make it executable.
        dnl AC_CONFIG_COMMANDS([run_tests_pmt], [chmod +x pmt/src/python/run_tests])
     ])