Merge commit 'v3.3.0' into upstream
[debian/gnuradio] / config / grc_omnithread.m4
index 77618e9023c74bf0e4ab291a70388812e0ca1b65..1bcedebe183e4dc82168bacba7408ef09d25ba7c 100644 (file)
@@ -18,39 +18,29 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_OMNITHREAD],[
-    GRC_ENABLE([omnithread])
-    GRC_WITH([omnithread])
-    passed=no
-    if test x$with_omnithread = xyes; then
-        if test x$enable_omnithread = xyes; then
-           AC_MSG_ERROR([Component omnithread: Cannot use both --enable and --with])
-        else
-           PKG_CHECK_MODULES(OMNITHREAD, gnuradio-omnithread, passed=with,
-                  AC_MSG_RESULT([Component omnithread: PKGCONFIG cannot find info]))
-            if test x$passed = xwith; then
-                omnithread_INCLUDES=`$PKG_CONFIG --cflags-only-I gnuradio-omnithread`
-               omnithread_LA=$OMNITHREAD_LIBS
-               omnithread_LIBDIRPATH=`$PKG_CONFIG --variable=libdir gnuradio-omnithread`
-            fi
-       fi
-    fi
-    dnl if $passed = with, then "--with" worked; ignore the "--enable" stuff
-    dnl otherwise, $passed = no; check the "--enable" stuff
-    if test x$passed = xno; then
-        AC_CONFIG_FILES([ \
-            omnithread/Makefile \
-           omnithread/gnuradio-omnithread.pc
-        ])
-        passed=yes
+    GRC_ENABLE(omnithread)
+
+    GRC_WITH(omnithread, [], gnuradio-omnithread)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed != with; then
+       dnl how and where to find INCLUDES and LA and such
         omnithread_INCLUDES="-I\${abs_top_srcdir}/omnithread"
         omnithread_LA="\${abs_top_builddir}/omnithread/libgromnithread.la"
        omnithread_LIBDIRPATH="\${abs_top_builddir}/omnithread:\${abs_top_builddir}/omnithread/.libs"
     fi
-    GRC_BUILD_CONDITIONAL([omnithread],[
+
+    AC_CONFIG_FILES([ \
+        omnithread/Makefile \
+        omnithread/gnuradio/Makefile \
+        omnithread/gnuradio-omnithread.pc
+    ])
+
+    GRC_BUILD_CONDITIONAL(omnithread,[
         dnl run_tests is created from run_tests.in.  Make it executable.
         dnl AC_CONFIG_COMMANDS([run_tests_omnithread], [chmod +x omnithread/run_tests])
     ])
-    AC_SUBST([omnithread_INCLUDES])
-    AC_SUBST([omnithread_LA])
-    AC_SUBST([omnithread_LIBDIRPATH])
 ])