make maintainer-clean removes these, and we want a clean orig.tar.gz
[debian/gnuradio] / config / grc_mblock.m4
index ec985e0530d4c13afe6e1601482304c0664022b8..e3ae1817f10966882e4b0ffd7e1837048d53d0a9 100644 (file)
@@ -18,58 +18,42 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_MBLOCK],[
-    GRC_ENABLE([mblock])
-    GRC_WITH([mblock])
-    passed=no
-    if test x$with_mblock = xyes; then
-        if test x$enable_mblock = xyes; then
-           AC_MSG_ERROR([Component mblock: Cannot use both --enable and --with])
-        else
-           PKG_CHECK_MODULES(MBLOCK, mblock, passed=with,
-                  AC_MSG_RESULT([Component mblock: PKGCONFIG cannot find info]))
-            if test x$passed = xwith; then
-                mblock_INCLUDES=`$PKG_CONFIG --cflags-only-I mblock`
-               mblock_LA=$MBLOCK_LIBS
-            fi
-       fi
+    GRC_ENABLE(mblock)
+
+    GRC_WITH(mblock)
+
+    dnl Don't do mblock if omnithread or pmt skipped
+    GRC_CHECK_DEPENDENCY(mblock, pmt)
+    GRC_CHECK_DEPENDENCY(mblock, omnithread)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+       dnl Don't do mblock if guile not available
+       GRC_CHECK_GUILE(mblock)
     fi
-    dnl if $passed = with, then "--with" worked; ignore the "--enable" stuff
-    dnl otherwise, $passed = no; check the "--enable" stuff
-    if test x$passed = xno; then
-        AC_CONFIG_FILES([\
-           mblock/Makefile \
-           mblock/mblock.pc \
-           mblock/doc/Makefile \
-           mblock/src/Makefile \
-           mblock/src/lib/Makefile \
-           mblock/src/scheme/Makefile \
-           mblock/src/scheme/gnuradio/Makefile \
-       ])
-       passed=yes
-       # Don't do mblock if omnithread or pmt skipped
-       if test x$omnithread_skipped = xyes; then
-           AC_MSG_RESULT([Component mblock requires omnithread, which is not being built or specified via pre-installed files.])
-           passed=no
-       fi
-       if test x$pmt_skipped = xyes; then
-           AC_MSG_RESULT([Component mblock requires pmt, which is not being built or specified via pre-installed files.])
-           passed=no
-       fi
-       # Don't do mblock if guile not available
-       AC_PATH_PROG(GUILE,guile)
-       if test "$GUILE" = "" ; then
-           AC_MSG_RESULT([Component mblock requires guile, which was not found.])
-           passed=no
-       fi
-       mblock_INCLUDES="-I\${abs_top_srcdir}/mblock/src/lib"
+    if test $passed != with; then
+       dnl how and where to find INCLUDES and LA
+       mblock_INCLUDES="-I\${abs_top_srcdir}/mblock/src/include"
         mblock_LA="\${abs_top_builddir}/mblock/src/lib/libmblock.la"
     fi
 
-    GRC_BUILD_CONDITIONAL([mblock],[
+    AC_CONFIG_FILES([\
+        mblock/Makefile \
+        mblock/mblock.pc \
+        mblock/doc/Makefile \
+        mblock/src/Makefile \
+       mblock/src/include/Makefile \
+       mblock/src/include/mblock/Makefile \
+        mblock/src/lib/Makefile \
+        mblock/src/scheme/Makefile \
+        mblock/src/scheme/gnuradio/Makefile \
+    ])
+
+    GRC_BUILD_CONDITIONAL(mblock,[
         dnl run_tests is created from run_tests.in.  Make it executable.
        dnl AC_CONFIG_COMMANDS([run_tests_mblock], [chmod +x mblock/src/python/run_tests])
     ])
-
-    AC_SUBST([mblock_INCLUDES], [$mblock_INCLUDES])
-    AC_SUBST([mblock_LA], [$mblock_LA])
 ])