Merged features/inband -r4812:5218 into trunk. This group of changes
[debian/gnuradio] / config / grc_mblock.m4
index 6e4bc4afe1cfbfc89c66f09ce09ad060e42011cf..d5020a65b49618a766a6abf08febe369e31e65c1 100644 (file)
@@ -24,7 +24,9 @@ AC_DEFUN([GRC_MBLOCK],[
        mblock/Makefile \
        mblock/doc/Makefile \
        mblock/src/Makefile \
-       mblock/src/lib/Makefile
+       mblock/src/lib/Makefile \
+       mblock/src/scheme/Makefile \
+       mblock/src/scheme/gnuradio/Makefile \
     ])
 
     passed=yes
@@ -48,6 +50,12 @@ AC_DEFUN([GRC_MBLOCK],[
        fi
     done
 
+    AC_PATH_PROG(GUILE,guile)
+    if test "$GUILE" = "" ; then
+      AC_MSG_RESULT([Component mblock requires guile, which was not found.])
+      passed=no
+    fi
+
     GRC_BUILD_CONDITIONAL([mblock],[
         dnl run_tests is created from run_tests.in.  Make it executable.
        dnl AC_CONFIG_COMMANDS([run_tests_mblock], [chmod +x mblock/src/python/run_tests])