Implements ticket:28. See BuildConfiguration for documentation.
[debian/gnuradio] / config / grc_gr_wxgui.m4
index f48fb2ab7dd3c36ba62c8177ebfdf8b660be52eb..c9eaec403d6ebc6cf6ec24032fb50362ce929c2c 100644 (file)
@@ -18,7 +18,7 @@ dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
 dnl Boston, MA 02111-1307, USA.
 
 AC_DEFUN([GRC_GR_WXGUI],[
-    AC_CONFIG_SRCDIR([gr-wxgui/src/python/stdgui.py])
+    GRC_ENABLE([gr-wxgui])
 
     AC_CONFIG_FILES([ \
          gr-wxgui/Makefile \
@@ -26,9 +26,13 @@ AC_DEFUN([GRC_GR_WXGUI],[
          gr-wxgui/src/python/Makefile \
     ])
 
+    # FIXME: this breaks pkgsrc by calling python without a version number
+    # gdt--patch welcome :-)
     if python -c 'import wx'; then
-       subdirs="$subdirs gr-wxgui"
+       passed=yes
     else
-       failed="$failed gr-wxgui"
+       passed=no
     fi
+    
+    GRC_BUILD_CONDITIONAL([gr-wxgui])
 ])