files are not required anymore
[debian/gnuradio] / config / grc_gr_video_sdl.m4
index c161b5f3e84ff69aeafda47dc78f22d6cc7eec67..5261533166579a6a75cd925f3441c34d22ba2cdc 100644 (file)
@@ -14,11 +14,11 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_VIDEO_SDL],[
-    AC_CONFIG_SRCDIR([gr-video-sdl/src/video_sdl.i])
+    GRC_ENABLE([gr-video-sdl])
 
     AC_CONFIG_FILES([ \
        gr-video-sdl/Makefile \
@@ -26,18 +26,15 @@ AC_DEFUN([GRC_GR_VIDEO_SDL],[
        gr-video-sdl/src/run_tests \
     ])
     
-    succeeded=yes
-    dnl Check for SDL
+    passed=yes
     SDL_VERSION=1.2.0
-    AM_PATH_SDL($SDL_VERSION,[],[succeeded=no])
+    AM_PATH_SDL($SDL_VERSION,[],
+        [passed=no;AC_MSG_RESULT([gr-video-sdl requires library sdl, not found or failed test.])])
 
-    if test $succeeded = yes; then
-        AM_CFLAGS="$AM_CFLAGS $SDL_CFLAGS"
-        AM_LDFLAGS="$AM_LDFLAGS $SDL_LIBS"
+    GRC_BUILD_CONDITIONAL([gr-video-sdl],[
+       AC_SUBST(SDL_CFLAGS)
+       AC_SUBST(SDL_LIBS)
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_sdl], [chmod +x gr-video-sdl/src/run_tests])
-        subdirs="$subdirs gr-video-sdl"
-    else
-       failed="$failed gr-video-sdl"
-    fi
+    ])
 ])