Added enabling group 'user' access to USRP hardware into Debian packaging.
[debian/gnuradio] / config / grc_gr_video_sdl.m4
index 1432ccd673d6ebf5fb652bad77f929accd9b6ec4..405feb0ea2016dba01e6e3f1550683874ec66f94 100644 (file)
@@ -4,7 +4,7 @@ dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,32 +14,27 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_VIDEO_SDL],[
-    AC_CONFIG_SRCDIR([gr-video-sdl/src/video_sdl.i])
+    GRC_ENABLE([gr-video-sdl])
 
-    succeeded=yes
-
-    dnl Check for SDL
+    AC_CONFIG_FILES([ \
+       gr-video-sdl/Makefile \
+       gr-video-sdl/src/Makefile \
+       gr-video-sdl/src/run_tests \
+    ])
+    
+    passed=yes
     SDL_VERSION=1.2.0
-    AM_PATH_SDL($SDL_VERSION,[],[succeeded=no])
-
-    if test $succeeded = yes; then
-        AM_CFLAGS="$AM_CFLAGS $SDL_CFLAGS"
-        AM_LDFLAGS="$AM_LDFLAGS $SDL_LIBS"
-
-        AC_CONFIG_FILES([\
-         gr-video-sdl/Makefile \
-         gr-video-sdl/src/Makefile \
-         gr-video-sdl/src/run_tests \
-       ])
+    AM_PATH_SDL($SDL_VERSION,[],
+        [passed=no;AC_MSG_RESULT([gr-video-sdl requires library sdl, not found or failed test.])])
 
+    GRC_BUILD_CONDITIONAL([gr-video-sdl],[
+       AC_SUBST(SDL_CFLAGS)
+       AC_SUBST(SDL_LIBS)
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_sdl], [chmod +x gr-video-sdl/src/run_tests])
-        subdirs="$subdirs gr-video-sdl"
-    else
-       failed="$failed gr-video-sdl"
-    fi
+    ])
 ])