cobble a temporary changelog entry to keep this test build straight
[debian/gnuradio] / config / grc_gr_utils.m4
index e5b3a6afbacf53eb58031e1ec42e3613e1fba684..7fe07d854f2ec0b15b11a60c1d83c5d134fc27f6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 2007 Free Software Foundation, Inc.
+# Copyright 2007,2008 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_UTILS],[
-    GRC_ENABLE([gr-utils])
+    GRC_ENABLE(gr-utils)
+
+    dnl Don't do gr-utils if gnuradio-core, usrp, or gr-wxgui skipped
+    GRC_CHECK_DEPENDENCY(gr-utils, gnuradio-core)
+    GRC_CHECK_DEPENDENCY(gr-utils, usrp)
+    GRC_CHECK_DEPENDENCY(gr-utils, gr-wxgui)
 
     AC_CONFIG_FILES([ \
         gr-utils/Makefile \
-       gr-utils/src/Makefile \
-       gr-utils/src/lib/Makefile \
-       gr-utils/src/python/Makefile \
+        gr-utils/src/Makefile \
+        gr-utils/src/lib/Makefile \
+        gr-utils/src/python/Makefile \
     ])
 
-    passed=yes
-    # Don't do gr-utils if gnuradio-core, usrp, or gr-wxgui skipped
-    # There *has* to be a better way to check if a value is in a string
-    for dir in $skipped_dirs
-    do
-       if test x$dir = xusrp; then
-           AC_MSG_RESULT([Component gr-utils requires usrp, which is not being built.])
-           passed=no
-       fi
-       if test x$dir = xgnuradio-core; then
-           AC_MSG_RESULT([Component gr-utils requires gnuradio-core, which is not being built.])
-           passed=no
-       fi
-       if test x$dir = xgr-wxgui; then
-           AC_MSG_RESULT([Component gr-utils requires gr-wxgui, which is not being built.])
-           passed=no
-       fi
-    done
-
-    GRC_BUILD_CONDITIONAL([gr-utils])
+    GRC_BUILD_CONDITIONAL(gr-utils)
 ])