Directory reorganization to newer layout
[debian/gnuradio] / config / grc_gr_sounder.m4
index 0553bb27708b35a8faa4c8abfe1e10559d7f453e..672d13ab1315fb33b7521e7c827a88478892adec 100644 (file)
@@ -18,33 +18,26 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_SOUNDER],[
-    GRC_ENABLE([gr-sounder])
+    GRC_ENABLE(gr-sounder)
+
+    dnl Don't do gr-sounder if usrp or gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-sounder, usrp)
+    GRC_CHECK_DEPENDENCY(gr-sounder, gnuradio-core)
 
     AC_CONFIG_FILES([ \
-        gr-sounder/Makefile \
-        gr-sounder/doc/Makefile \
-        gr-sounder/src/Makefile \
-        gr-sounder/src/fpga/Makefile \
-        gr-sounder/src/fpga/top/Makefile \
-         gr-sounder/src/fpga/lib/Makefile \
-        gr-sounder/src/fpga/tb/Makefile \
-        gr-sounder/src/lib/Makefile \
-        gr-sounder/src/python/Makefile \
-         gr-sounder/src/python/run_tests
+        gr-sounder/Makefile \
+        gr-sounder/doc/Makefile \
+        gr-sounder/src/Makefile \
+        gr-sounder/src/fpga/Makefile \
+        gr-sounder/src/fpga/top/Makefile \
+        gr-sounder/src/fpga/lib/Makefile \
+        gr-sounder/src/fpga/tb/Makefile \
+        gr-sounder/src/lib/Makefile \
+        gr-sounder/src/python/Makefile \
+        gr-sounder/src/python/run_tests
     ])
 
-    passed=yes
-    # Don't do gr-sounder if usrp or gnuradio-core skipped
-    if test x$usrp_skipped = xyes; then
-        AC_MSG_RESULT([Component gr-sounder requires usrp, which is not being built or specified via pre-installed files.])
-        passed=no
-    fi
-    if test x$gnuradio_core_skipped = xyes; then
-        AC_MSG_RESULT([Component gr-sounder requires gnuradio-core, which is not being built or specified via pre-installed files.])
-       passed=no
-    fi
-
-    GRC_BUILD_CONDITIONAL([gr-sounder],[
+    GRC_BUILD_CONDITIONAL(gr-sounder,[
        dnl run_tests is created from run_tests.in.  Make it executable.
        AC_CONFIG_COMMANDS([run_tests_sounder], [chmod +x gr-sounder/src/python/run_tests])
     ])