Implements ticket:28. See BuildConfiguration for documentation.
[debian/gnuradio] / config / grc_gr_radio_astronomy.m4
index 0b445dbcbf58e4e32ad468051a4487774bdd52df..16744d5e438de9eb03563683ca029fa9204e2bac 100644 (file)
@@ -18,7 +18,7 @@ dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
 dnl Boston, MA 02111-1307, USA.
 
 AC_DEFUN([GRC_GR_RADIO_ASTRONOMY],[
-    AC_CONFIG_SRCDIR([gr-radio-astronomy/src/lib/ra.i])
+    GRC_ENABLE([gr-radio-astronomy])
 
     AC_CONFIG_FILES([\
        gr-radio-astronomy/Makefile \
@@ -28,8 +28,9 @@ AC_DEFUN([GRC_GR_RADIO_ASTRONOMY],[
        gr-radio-astronomy/src/python/run_tests \
     ])
 
-    dnl run_tests is created from run_tests.in.  Make it executable.
-    AC_CONFIG_COMMANDS([run_tests_astronomy], [chmod +x gr-radio-astronomy/src/python/run_tests])
-
-    subdirs="$subdirs gr-radio-astronomy"
+    passed=yes
+    GRC_BUILD_CONDITIONAL([gr-radio-astronomy],[
+        dnl run_tests is created from run_tests.in.  Make it executable.
+        AC_CONFIG_COMMANDS([run_tests_astronomy], [chmod +x gr-radio-astronomy/src/python/run_tests])
+    ])
 ])