Merged r10071:10164 from features/cppdb-test into trunk. Implements the fully native...
[debian/gnuradio] / config / grc_gr_qtgui.m4
index 479c15a3f686ca206eeba0196988184614d17ca5..54bdb2d3b755bc4877e489f7e5538ef20f9c4abe 100644 (file)
@@ -27,20 +27,68 @@ AC_DEFUN([GRC_GR_QTGUI],[
     dnl   with : if the --with code didn't error out
     dnl   yes  : if the --enable code passed muster and all dependencies are met
     dnl   no   : otherwise
-    if test $passed = yes; then
-       dnl Check for package qt or qt-mt, set QT_CFLAGS and QT_LIBS
-        PKG_CHECK_MODULES(QT, qt >= 3.3, [], [
-           PKG_CHECK_MODULES(QT, qt-mt >= 3.3, [],
-               [passed=no;AC_MSG_RESULT([gr-qtgui requires libqt or libqt-mt, neither found.])])])
 
+
+# Check for: 
+#      QtOpenGL
+#      QtGui
+#      QtCore
+#      qwt 
+#      qwtplot3d
+#      qt4
+
+# qt4-core, qt4-gui, qwt5-qt4, qwt5-qt4-dev, libqwtplot3d-qt4, libqwtplot3d-qt4-dev, qt4-dev-tools
+
+    if test $passed = yes; then
+        dnl Check for package qt or qt-mt, set QT_CFLAGS and QT_LIBS
+        PKG_CHECK_MODULES(QTCORE, QtCore >= 4.3.4, [],
+           [passed=no; AC_MSG_RESULT([gr-qtgui requires libQtCore.])])
+        PKG_CHECK_MODULES(QTGUI, QtGui >= 4.3.4, [],
+           [passed=no; AC_MSG_RESULT([gr-qtgui requires libQtGui.])])
+        PKG_CHECK_MODULES(QTOPENGL, QtOpenGL >= 4.3.4, [],
+           [passed=no; AC_MSG_RESULT([gr-qtgui requires libQtOpenGL.])])
+       
         dnl Fetch QWT variables
         GR_QWT([], [passed=no])
+
+        dnl Process QWT Plot3D only if QWT passed
+       if test "$passed" = "yes"; then
+            GR_QWTPLOT3D([], [passed=no])
+        fi
+
+       dnl Export the include dirs and libraries (note: QTOPENGL_LIBS includes links
+       dnl to QtCore and QtGui libraries)
+       QT_INCLUDES="$QWT_CFLAGS $QWTPLOT3D_CFLAGS $QTCORE_CFLAGS $QTGUI_CFLAGS"
+       QT_LIBS="$QWT_LIBS $QWTPLOT3D_LIBS $QTOPENGL_LIBS"
+
+        dnl Build an includes variable specifically for running qmake by extracting
+        dnl all includes from the QWT and QWTPLOT3D, without the -I;
+        dnl qmake appends the -I when processing the project file INCLUDEPATH
+        for i in $QWT_CFLAGS $QWTPLOT3D_CFLAGS; do
+            QMAKE_INCLUDES="$QMAKE_INCLUDES ${i##-I}"
+        done
+
+       QT_MOC_EXEC=`pkg-config --variable=moc_location QtCore`
+       QT_UIC_EXEC=`pkg-config --variable=uic_location QtCore`
+
+        AC_SUBST(QMAKE_INCLUDES)
+        AC_SUBST(QT_INCLUDES)
+       AC_SUBST(QT_LIBS)
+       AC_SUBST(QT_MOC_EXEC)
+       AC_SUBST(QT_UIC_EXEC)
+    fi
+
+    if test "$passed" = "no"; then
+        AM_CONDITIONAL(BUILD_QT, false)
+    else
+       AM_CONDITIONAL(BUILD_QT, true)
     fi
 
     AC_CONFIG_FILES([ \
         gr-qtgui/Makefile \
         gr-qtgui/src/Makefile \
         gr-qtgui/src/lib/Makefile \
+        gr-qtgui/src/python/Makefile \
     ])
 
     GRC_BUILD_CONDITIONAL(gr-qtgui)