another distcheck fix
[debian/gnuradio] / config / grc_gr_qtgui.m4
index aa8ca7c89125770b306f7e349688f0e2d428a156..479c15a3f686ca206eeba0196988184614d17ca5 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -18,29 +18,30 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_QTGUI],[
-    GRC_ENABLE([gr-qtgui])
+    GRC_ENABLE(gr-qtgui)
 
-    AC_CONFIG_FILES([ \
-         gr-qtgui/Makefile \
-         gr-qtgui/src/Makefile \
-         gr-qtgui/src/lib/Makefile \
-    ])
+    dnl Don't do gr-qtgui if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-qtgui, gnuradio-core)
 
-    passed=yes
-    PKG_CHECK_MODULES(QT, qt >= 3.3,[],
-    [passed=no;AC_MSG_RESULT([gr-qtgui requires qt, not found. Checking for qt-mt])])
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+       dnl Check for package qt or qt-mt, set QT_CFLAGS and QT_LIBS
+        PKG_CHECK_MODULES(QT, qt >= 3.3, [], [
+           PKG_CHECK_MODULES(QT, qt-mt >= 3.3, [],
+               [passed=no;AC_MSG_RESULT([gr-qtgui requires libqt or libqt-mt, neither found.])])])
 
-    if test x$passed == xno; then
-       passed=yes
-       PKG_CHECK_MODULES(QT, qt-mt >= 3.3,[],
-       [passed=no;AC_MSG_RESULT([gr-qtgui requires qt, not found. Checking for qt-mt])])
+        dnl Fetch QWT variables
+        GR_QWT([], [passed=no])
     fi
 
-    AC_HAVE_LIBRARY(qwt, [],
-       [passed=no;AC_MSG_RESULT([gr-qtgui requires qwt, not found.])])
+    AC_CONFIG_FILES([ \
+        gr-qtgui/Makefile \
+        gr-qtgui/src/Makefile \
+        gr-qtgui/src/lib/Makefile \
+    ])
 
-    
-    GRC_BUILD_CONDITIONAL([gr-qtgui], [
-    AC_SUBST(QT_LIBS)
-    AC_SUBST(QWT_LIBS)])
+    GRC_BUILD_CONDITIONAL(gr-qtgui)
 ])