]> git.gag.com Git - debian/gnuradio/blobdiff - config/grc_gr_pager.m4
Added gr-pager component to trunk by merging from r3474:r3537 in
[debian/gnuradio] / config / grc_gr_pager.m4
diff --git a/config/grc_gr_pager.m4 b/config/grc_gr_pager.m4
new file mode 100644 (file)
index 0000000..2c859ee
--- /dev/null
@@ -0,0 +1,34 @@
+dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl 
+dnl This file is part of GNU Radio
+dnl 
+dnl GNU Radio is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 2, or (at your option)
+dnl any later version.
+dnl 
+dnl GNU Radio is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+dnl GNU General Public License for more details.
+dnl 
+dnl You should have received a copy of the GNU General Public License
+dnl along with GNU Radio; see the file COPYING.  If not, write to
+dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+dnl Boston, MA 02111-1307, USA.
+
+AC_DEFUN([GRC_GR_PAGER],[
+    GRC_ENABLE([gr-pager])
+
+    AC_CONFIG_FILES([\
+       gr-pager/Makefile \
+       gr-pager/src/Makefile \
+       gr-pager/src/run_tests
+    ])
+
+    passed=yes
+    GRC_BUILD_CONDITIONAL([gr-pager],[
+        dnl run_tests is created from run_tests.in.  Make it executable.
+        AC_CONFIG_COMMANDS([run_tests_pager], [chmod +x gr-pager/src/run_tests])
+    ])
+])