Imported Upstream version 3.2.2
[debian/gnuradio] / config / grc_gr_gcell.m4
diff --git a/config/grc_gr_gcell.m4 b/config/grc_gr_gcell.m4
new file mode 100644 (file)
index 0000000..476de36
--- /dev/null
@@ -0,0 +1,38 @@
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008,2009 Free Software Foundation, Inc.
+dnl 
+dnl This file is part of GNU Radio
+dnl 
+dnl GNU Radio is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 3, or (at your option)
+dnl any later version.
+dnl 
+dnl GNU Radio is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+dnl GNU General Public License for more details.
+dnl 
+dnl You should have received a copy of the GNU General Public License
+dnl along with GNU Radio; see the file COPYING.  If not, write to
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
+
+AC_DEFUN([GRC_GR_GCELL],[
+    GRC_ENABLE(gr-gcell)
+
+    dnl Don't do gr-gcell if gcell or gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-gcell, gcell)
+    GRC_CHECK_DEPENDENCY(gr-gcell, gnuradio-core)
+
+    AC_CONFIG_FILES([ \
+        gr-gcell/Makefile \
+        gr-gcell/src/Makefile \
+        gr-gcell/src/examples/Makefile \
+        gr-gcell/src/run_tests \
+    ])
+
+    GRC_BUILD_CONDITIONAL(gr-gcell,[
+       dnl run_tests is created from run_tests.in.  Make it executable.
+       AC_CONFIG_COMMANDS([run_tests_gcell], [chmod +x gr-gcell/src/run_tests])
+    ])
+])