Fix missing files in distribution tarball (Dan Halperin).
[debian/gnuradio] / config / grc_gr_audio_windows.m4
index 64d482e814b91c2a5f917501b25112d427ca7f3b..c34651eda8e102cd58e14a51badd88998aab02da 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,11 +14,11 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_WINDOWS],[
-    AC_CONFIG_SRCDIR([gr-audio-windows/src/audio_windows.i])
+    GRC_ENABLE([gr-audio-windows])
 
     AC_CONFIG_FILES([ \
        gr-audio-windows/Makefile \
@@ -26,17 +26,21 @@ AC_DEFUN([GRC_GR_AUDIO_WINDOWS],[
        gr-audio-windows/src/run_tests \
     ])
 
-    succeeded=yes
-    AC_HAVE_LIBRARY(winmm,[],[succeeded=no])
+    passed=yes
+    # Don't do gr-audio-windows if gnuradio-core skipped
+    if test x$gnuradio_core_skipped = xyes; then
+        AC_MSG_RESULT([Component gr-audio-windows requires gnuradio-core, which is not being built or specified via pre-installed files.])
+       passed=no
+    fi
+
+    # Don't do gr-audio-windows if the 'winmm' library isn't available.
+    AC_HAVE_LIBRARY(winmm,[],
+        [passed=no;AC_MSG_RESULT([gr-audio-windows requires library winmm, not found.])])
 
-    if test $succeeded = yes; then
+    GRC_BUILD_CONDITIONAL([gr-audio-windows],[
        WINAUDIO_LIBS=-lwinmm
        AC_SUBST(WINAUDIO_LIBS)
-
        dnl run_tests is created from run_tests.in.  Make it executable.
-        AC_CONFIG_COMMANDS([run_tests_windows], [chmod +x gr-audio-windows/src/run_tests])
-        subdirs="$subdirs gr-audio-windows"
-    else
-       failed="$failed gr-audio-windows"
-    fi
+        AC_CONFIG_COMMANDS([run_tests_audio_windows], [chmod +x gr-audio-windows/src/run_tests])
+    ])
 ])