make maintainer-clean removes these, and we want a clean orig.tar.gz
[debian/gnuradio] / config / grc_gr_audio_portaudio.m4
index 193e2e3135964a9b6ac7f59805ba78f3d59011cc..ff551b38a77df1f07928e72d96daf9a617cff8c3 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,28 +14,34 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_PORTAUDIO],[
-    AC_CONFIG_SRCDIR([gr-audio-portaudio/src/audio_portaudio.i])
+    GRC_ENABLE(gr-audio-portaudio)
 
-    succeeded=yes
-    PKG_CHECK_MODULES(PORTAUDIO, portaudio-2.0 >= 19,[],[succeeded=no])
-    #AC_HAVE_LIBRARY([portaudio], [], [succeeded=no])
-    #AC_CHECK_HEADER([portaudio.h], [], [succeeded=no])
-    if test $succeeded = yes; then
-        AC_CONFIG_FILES([\
-         gr-audio-portaudio/Makefile \
-         gr-audio-portaudio/src/Makefile \
-         gr-audio-portaudio/src/run_tests \
-       ])
+    dnl Don't do gr-audio-portaudio if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-audio-portaudio, gnuradio-core)
 
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        dnl Don't do gr-audio-portaudio if the 'portaudio' library is unavailable.
+        PKG_CHECK_MODULES(PORTAUDIO, portaudio-2.0 >= 19,[],
+            [passed=no;AC_MSG_RESULT([gr-audio-portaudio requires package portaudio, not found.])])
+    fi
+
+    AC_CONFIG_FILES([ \
+        gr-audio-portaudio/Makefile \
+       gr-audio-portaudio/gnuradio-audio-portaudio.pc \
+        gr-audio-portaudio/src/Makefile \
+        gr-audio-portaudio/src/run_tests \
+    ])
+
+    GRC_BUILD_CONDITIONAL(gr-audio-portaudio,[
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_portaudio], [chmod +x gr-audio-portaudio/src/run_tests])
-        subdirs="$subdirs gr-audio-portaudio"
-    else
-       AC_MSG_RESULT([failed: $PORTAUDIO_PKG_ERRORS])
-       failed="$failed gr-audio-portaudio"
-    fi
+    ])
 ])