Added enabling group 'user' access to USRP hardware into Debian packaging.
[debian/gnuradio] / config / grc_gr_audio_portaudio.m4
index a4614660415f58dfe60e3708530f85843918972a..31ab07aab7be8beb9419fcaf4c2ae33b3ae591e0 100644 (file)
@@ -4,7 +4,7 @@ dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,11 +14,11 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_PORTAUDIO],[
-    AC_CONFIG_SRCDIR([gr-audio-portaudio/src/audio_portaudio.i])
+    GRC_ENABLE([gr-audio-portaudio])
 
     AC_CONFIG_FILES([ \
        gr-audio-portaudio/Makefile \
@@ -26,16 +26,13 @@ AC_DEFUN([GRC_GR_AUDIO_PORTAUDIO],[
        gr-audio-portaudio/src/run_tests \
     ])
 
-    succeeded=yes
-    PKG_CHECK_MODULES(PORTAUDIO, portaudio-2.0 >= 19,[],[succeeded=no])
-    #AC_HAVE_LIBRARY([portaudio], [], [succeeded=no])
-    #AC_CHECK_HEADER([portaudio.h], [], [succeeded=no])
-    if test $succeeded = yes; then
+    passed=yes
+    PKG_CHECK_MODULES(PORTAUDIO, portaudio-2.0 >= 19,[],
+        [passed=no;AC_MSG_RESULT([gr-audio-portaudio requires package portaudio, not found.])])
+
+    GRC_BUILD_CONDITIONAL([gr-audio-portaudio],[
+       AC_SUBST(PORTAUDIO_LIBS)
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_portaudio], [chmod +x gr-audio-portaudio/src/run_tests])
-        subdirs="$subdirs gr-audio-portaudio"
-    else
-       AC_MSG_RESULT([failed: $PORTAUDIO_PKG_ERRORS])
-       failed="$failed gr-audio-portaudio"
-    fi
+    ])
 ])