files are not required anymore
[debian/gnuradio] / config / grc_gr_audio_oss.m4
index b0190d687da1a07751201be5dcc0b7b4e8677605..d7abe90077ff8da2a3de154ce9dbc7f15ed3c554 100644 (file)
@@ -14,32 +14,36 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_OSS],[
-    AC_CONFIG_SRCDIR([gr-audio-oss/src/audio_oss.i])
+    GRC_ENABLE([gr-audio-oss])    
 
-    succeeded=yes
+    AC_CONFIG_FILES([ \
+       gr-audio-oss/Makefile \
+       gr-audio-oss/src/Makefile \
+       gr-audio-oss/src/run_tests \
+    ])
 
-    dnl needed for NetBSD
-    dnl FIXME: conditionalize on NetBSD platform
-    dnl AC_HAVE_LIBRARY(ossaudio,[],[succeeded=no])
-
-    AC_CHECK_HEADER(sys/soundcard.h,[],[succeeded=no])
-    if test $succeeded = yes; then
-
-        AC_CONFIG_FILES([\
-         gr-audio-oss/Makefile \
-         gr-audio-oss/src/Makefile \
-         gr-audio-oss/src/run_tests \
-       ])
+    passed=yes
+    case $target in
+       *-*-netbsd*)
+           AC_HAVE_LIBRARY(ossaudio,[],
+               [passed=no;AC_MSG_RESULT([gr-audio-oss requires library ossaudio, not found.])])
+           if test x$passed != xno; then
+               OSS_LIBS=-lossaudio
+               AC_MSG_RESULT([Using OSS library $OSS_LIBS])
+           fi
+           ;;
+       *)
+           AC_CHECK_HEADER(sys/soundcard.h,[],
+               [passed=no;AC_MSG_RESULT([gr-audio-oss requires sys/soundcard.h, not found.])])
+    esac
 
+    GRC_BUILD_CONDITIONAL([gr-audio-oss],[
+       AC_SUBST(OSS_LIBS)
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_oss], [chmod +x gr-audio-oss/src/run_tests])
-        subdirs="$subdirs gr-audio-oss"
-    else
-       AC_MSG_RESULT([failed: $OSS_PKG_ERRORS])
-       failed="$failed gr-audio-oss"
-    fi
+    ])
 ])